Bug 20645 - internal compiler error: program cc1 got fatal signal 11
internal compiler error: program cc1 got fatal signal 11
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: egcs (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-10 11:20 EST by John Bollinger
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-13 06:14:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Bollinger 2000-11-10 11:20:08 EST
RedHat 6.2 installation on my Sony VAIO was a breeze, and I have since installed all of the relevant updates
as of November 9, 2000.  That much is good.  However, when I "make" a complicated source tree I frequently
get compiler crashes reporting "internal compiler error: program cc1 got fatal signal 11".  Typically I can restart
the make and it will pick up where it left off.  This happened half a dozen times as I built a new kernel from the
stock 2.2.17 source (the running kernel was 2.2.14-whatever from the original RPM).  It has since happened
as I built the pcmcia utilities for my new kernel (under my new kernel).  So far I have seen no other sign of
system instability.

"gcc --version" reports egcs-2.91.66

The system also dual boots Windows 98, and I have seen no evidence of any kind instability there (but then,
it's Windows -- how would I know? :-) )
Comment 1 Jakub Jelinek 2000-11-13 06:14:44 EST
If the segfaults are not reproduceable (go away when you start gcc on the
same file next time), then it is 99.5% bad hardware (either memory chip problems,
or overheated CPU, or something of that kind).
A compilation stresses the machine much more than plain running X or Win9x.
So, please check out whether if you get segfault on a particular file that
if you run the same command again it segfaults again. If not, please check your
hardware.

Note You need to log in before you can comment on or make changes to this bug.