This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 206450 - (addPTAdisabled) pass thru auth plugin should be configured by default
pass thru auth plugin should be configured by default
Status: CLOSED NOTABUG
Product: 389
Classification: Community
Component: Server - Plugins (Show other bugs)
1.0.2
All All
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
:
Depends On:
Blocks: 152373 fds103trackingbug 240316
  Show dependency treegraph
 
Reported: 2006-09-14 10:13 EDT by Rich Megginson
Modified: 2015-01-04 18:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 16:27:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
diffs for fix (1.69 KB, text/plain)
2006-09-14 10:41 EDT, Rich Megginson
no flags Details

  None (edit)
Description Rich Megginson 2006-09-14 10:13:17 EDT
If you do a core DS build, you don't have a config DS or a user DS, and
therefore the pass thru auth plugin is not added to the server config.  It
should always be added, disabled if not used immediately.
Comment 1 Rich Megginson 2006-09-14 10:41:40 EDT
Created attachment 136265 [details]
diffs for fix

If no config ds or user ds, just add the pta config to the server, disabled.
Comment 2 Rich Megginson 2006-09-14 16:30:40 EDT
Reviewed by: rcritten (Thanks!)
Fix Description: If you do a core DS build, you don't have a config DS or a user
DS, and
therefore the pass thru auth plugin is not added to the server config.  It
should always be added, disabled if not used immediately.  The fix is to add it
in this case, disabled.
Platforms tested: RHEL4
Flag Day: no
Doc impact: no

Checking in create_instance.c;
/cvs/dirsec/ldapserver/ldap/admin/src/create_instance.c,v  <--  create_instance.c
new revision: 1.28; previous revision: 1.27
done
Comment 3 Rich Megginson 2008-01-02 16:27:31 EST
This bug is not applicable for 8.0 because create_instance.c is gone.  However,
the new setup code does this.

Note You need to log in before you can comment on or make changes to this bug.