Bug 206471 - mkinitd - selinux and awk warnings
mkinitd - selinux and awk warnings
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-14 12:18 EDT by Peter Jones
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 10:14:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Jones 2006-09-14 12:18:54 EDT
+++ This bug was initially created as a clone of Bug #203380 +++

mkinitrd produces SELinux and other error messages

The case I see this is

login as root
cd to an NFS directory
make modules_install
cp arch/x86_64/boot/bzImage /boot/vmlinuz.ac

[so far so good]

mkinitrd /boot/vmlinuz.ac 2.6.18-rc4-mm2 

[Several {search} SELinux errors]
Two awk warnings about treating \] as ]

End result appears to be fine (but I'm not in enforcing mode]

-- Additional comment from pjones@redhat.com on 2006-09-14 11:19 EST --
I've fixed the awk error in CVS; as for the SELinux errors, that probably needs
to  be filed against policy; I'll dupe this for it.
Comment 1 Daniel Walsh 2006-09-15 10:19:56 EDT
Could you attach the avc messages.
Comment 2 Chris Lumens 2006-09-16 17:13:50 EDT
*** Bug 206742 has been marked as a duplicate of this bug. ***
Comment 3 Alan Cox 2006-09-26 18:17:24 EDT
I'll see if I can find the t2 CD set. Can't test t3 or rawhide as none of them
currently boot on my boxes.
Comment 4 Daniel Walsh 2006-10-04 15:01:23 EDT
Fixed in selinux-policy-2.3.18-2
Comment 5 Daniel Walsh 2007-08-22 10:14:02 EDT
Should be fixed in the current release

Note You need to log in before you can comment on or make changes to this bug.