Bug 206505 - Can't load larger ramdisk from network
Summary: Can't load larger ramdisk from network
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yaboot   
(Show other bugs)
Version: rawhide
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-14 19:15 UTC by Chris Adams
Modified: 2008-01-25 19:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-25 19:58:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Adams 2006-09-14 19:15:58 UTC
When trying to help a cow-orker load the current rawhide tree on an iBook G4,
yaboot gives "method 'load' failed 00000300" while loading the ramdisk from the
network.  The FC5 installer will load okay from the network.

After Googling, it appears to be related to the size of the image.  I stripped
out some unneeded modules (SCSI device modules for Adaptec and Qlogic), the
image is small enough to work.

Either yaboot needs to use a larger buffer or the ramdisk image needs to be
slimmed down by default.

Comment 1 Paul Nasrat 2006-11-16 13:36:41 UTC
Just a larger buffer doesn't fix it here, we need to rework the mmap
implementation for larger than the current limit.  Apple firmware deals with
slightly larger than 6M but IBM will fail past the current limit.  I have some
patches I'm looking at for this for yaboot HEAD.

Comment 2 Red Hat Bugzilla 2007-08-21 05:26:31 UTC
User pnasrat@redhat.com's account has been closed

Comment 3 Chris Adams 2008-01-25 19:58:24 UTC
I'm resolving this as UPSTREAM because it really is an upstream source problem.


Note You need to log in before you can comment on or make changes to this bug.