Bug 206516 - (CVE-2006-5129) CVE-2006-4784, CVE-2006-4785, CVE-2006-4786: moodle multiple vulnerabilities
CVE-2006-4784, CVE-2006-4785, CVE-2006-4786: moodle multiple vulnerabilities
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: moodle (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-14 15:53 EDT by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-27 10:09:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2006-09-14 15:53:31 EDT
Moodle 1.6.1 and earlier are reportedly vulnerable to:
- cross site scripting (CVE-2006-4784)
- SQL injection (CVE-2006-4785)
- sensitive information disclosure (CVE-2006-4786)

FE-4, FE-5 and devel apparently affected.
Comment 1 Jason Tibbitts 2006-09-14 16:21:39 EDT
At this time I'm having difficulty verifying that the 1.5.4 release is
vulnerable.  Secunia is still saying 1.6.x, and that other versions may be
vulnerable.  Moodle.org doesn't have anything to say about the matter other than
the 1.6.2 release indicating security fixes.  (The 1.5 branch is still
maintained, but shows no related changes.)
Comment 2 Mike McGrath 2006-09-14 22:33:16 EDT
I'll keep my eye open as well, I'll probably just update for update's sake
though there's some patches I don't fully understand being applied to that
packge.  (new maintainer)
Comment 3 Jason Tibbitts 2006-09-14 23:30:56 EDT
Let me know if you need assistance.  I have some experience with Moodle but no
longer use it here; I updated the package previously to deal with a security
issue but I have little interest in maintaining it in the long term.

I admit to being confused by the patches as well; I understand what they're
doing but I don't really understand why they need to be applied.  And of course
there's no documentation.  I'm beginning to think that we should require that
all patches have at least a line of comment in the spec file indicating what
they change and why they need to be applied.
Comment 5 Mike McGrath 2006-09-27 15:31:15 EDT
Actually I'd really appreciate that, I haven't had time to sit down and really
look at what the patches do.  I took this from ignacio because I felt it was
important enough to make sure it was maintained and because no one else wanted
it :D.  

tibbs: If you have some time and can help me out, by all means have at it.

I'm not against removing the patches to see what happens, people may not even be
using them.
Comment 6 Jason Tibbitts 2006-09-27 16:36:03 EDT
As far as I can tell, none of the CVEs in comment #4 apply to moodle 1.5.4.
Comment 7 Ville Skyttä 2006-10-10 14:24:59 EDT
Yet one more for 1.6.2: http://nvd.nist.gov/nvd.cfm?cvename=CVE-2006-5219

If this new doesn't affect the packaged versions and all the earlier reported 
ones have been verified to not affect them either, perhaps someone who has 
done the verification could close this bug?
Comment 8 Mike McGrath 2006-10-13 16:30:08 EDT
FYI, I've been working to update this to 1.6.3.  I'm going to release a version
to devel today.  FC[4-5] to follow.
Comment 9 Mike McGrath 2006-10-27 10:09:10 EDT
No one has complained, I'll be rebuilding FC4 and 5 immediately.

Note You need to log in before you can comment on or make changes to this bug.