Bug 206538 - Installation aborts if DHCP unchecked and IP fields empty
Installation aborts if DHCP unchecked and IP fields empty
Status: CLOSED DUPLICATE of bug 206537
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-14 17:57 EDT by Jason Farrell
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-14 18:07:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Farrell 2006-09-14 17:57:52 EDT
Description of problem:
Installation of FC6T3 aborts at Network setup step if "Use DHCP" in the device 
dialog is unchecked and nothing is input in the IP fields.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Go through default install steps until reaching Network devices setup step
2. Select a device (ie "eth0") and click Edit
3. Uncheck the "Use DHCP" checkbox
4. Click OK
  
Actual results:
Installation aborts because of unhandled exception


Expected results:
Input validation of required fields that are empty or bogus

Additional info:

Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/network_gui.py", line 456, in editDevice
    if int(val) > 32 or int(val) < 0:
ValueError: invalid literal for int():
Comment 1 Jason Farrell 2006-09-14 18:00:47 EDT
Sorry for the dupe -- I got the following error when posting: ""The product 
name '' is invalid or does not exist. Please press Back and try again.""
Comment 2 Jeremy Katz 2006-09-14 18:07:39 EDT

*** This bug has been marked as a duplicate of 206537 ***

Note You need to log in before you can comment on or make changes to this bug.