Bug 206541 - Can't install if a reiserfs partition is found
Can't install if a reiserfs partition is found
Status: CLOSED DUPLICATE of bug 206036
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-14 18:46 EDT by Jason Farrell
Modified: 2015-01-04 17:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-17 01:34:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Farrell 2006-09-14 18:46:20 EDT
Description of problem:
Installation of FC6T3 aborts at the early "findrootparts" step if a reiser fs 
partition happens to be found.

Version-Release number of selected component (if applicable):


How reproducible:
Both in VMWare with a virtual disk preformatted (using a knoppix livecd) with 
an extra reiser partition, as well as on my FC5 desktop with a spare partition 
that contains a reiserfs OpenSuSE 10.1 installation. After using "dd" to 
temporarily backup and zero out of the first 1MB of my SuSE partition, 
installation continued as normal.


Steps to Reproduce:
1. mkfs.reiserfs a partition that will be detected by anaconda.
2. perform a default installation

  
Actual results:
Installation aborts. If a graphical install, the screen goes black with the 
mouse cursor stuck in wait state.


Expected results:
Installation to continue as normal.

Additional info:
<6>EXT3 FS on hdd3, internal journal
<6>EXT3-fs: mounted filesystem with ordered data mode.
<6>SELinux: initialized (dev hdd3, type ext3), uses xattr
<5>ReiserFS: hdd6: found reiserfs format "3.6" with standard journal
<5>ReiserFS: hdd6: using ordered data mode
<5>ReiserFS: hdd6: journal params: device hdd6, size 8192, journal first block 
18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
<5>ReiserFS: hdd6: checking transaction log (hdd6)
<5>ReiserFS: hdd6: Using r5 hash to sort names
<6>SELinux: initialized (dev hdd6, type reiserfs), uses genfs_contexts
<3>BUG: Dentry f61abe1c{i=3,n=.reiserfs_priv} still in use (1) [unmount of 
reiserfs hdd6]
<0>------------[ cut here ]------------
<0>kernel BUG at fs/dcache.c:615!
<0>invalid opcode: 0000 [#1]
<1>last sysfs file: /block/ram0/dev
<4>Modules linked in: dm_emc dm_round_robin dm_multipath dm_snapshot dm_mirror 
dm_zero dm_mod xfs jfs reiserfs lock_nolock gfs2 ext3 jbd msdos raid456 xor 
raid1 raid0 usb_storage sata_nv forcedeth sky2 sata_sil libata ohci1394 
ieee1394 ohci_hcd ehci_hcd iscsi_tcp libiscsi scsi_transport_iscsi sr_mod 
sd_mod scsi_mod ide_cd cdrom ipv6 squashfs pcspkr edd floppy loop nfs nfs_acl 
fscache lockd sunrpc vfat fat cramfs
<0>CPU:    0
<4>EIP:    0060:[<c0473678>]    Not tainted VLI
<4>EFLAGS: 00010246   (2.6.17-1.2630.fc6 #1) 
<0>EIP is at shrink_dcache_for_umount_subtree+0x146/0x1d6
<0>eax: 0000005a   ebx: f61abe1c   ecx: f7a43eb8   edx: c06175d5
<0>esi: 00000001   edi: f7a56d8c   ebp: f7a43ee0   esp: f7a43eb4
<0>ds: 007b   es: 007b   ss: 0068
<0>Process anaconda (pid: 870, ti=f7a43000 task=f7a52ac0 task.ti=f7a43000)
<0>Stack: c06175d5 f61abe1c 00000003 f61abea4 00000001 f8c5a088 f7a56d8c 
00000003 
<0>       f7a56b14 f8c6da80 00000000 f7a43eec c0474128 f7a56b14 f7a43efc 
c0464ae8 
<0>       f621a3a4 f7a56b14 f7a43f0c c0464bc2 f7a56b14 f8c6da40 f7a43f1c 
c0464c82 
<0>Call Trace:
<4> [<c0474128>] shrink_dcache_for_umount+0x30/0x3d
<4> [<c0464ae8>] generic_shutdown_super+0x19/0xd3
<4> [<c0464bc2>] kill_block_super+0x20/0x32
<4> [<c0464c82>] deactivate_super+0x5d/0x6f
<4> [<c04775f7>] mntput_no_expire+0x42/0x71
<4> [<c046a4ba>] path_release_on_umount+0x15/0x18
<4> [<c0478707>] sys_umount+0x1d3/0x207
<4> [<c0478748>] sys_oldumount+0xd/0xf
<4> [<c0402e57>] syscall_call+0x7/0xb
<4>DWARF2 unwinder stuck at syscall_call+0x7/0xb
<4>Leftover inexact backtrace:
<4> [<c040397e>] show_stack_log_lvl+0x8a/0x95
<4> [<c0403aae>] show_registers+0x125/0x192
<4> [<c0403c7a>] die+0x15f/0x262
<4> [<c05f53e6>] do_trap+0x7c/0x96
<4> [<c040439f>] do_invalid_op+0x89/0x93
<4> [<c0403179>] error_code+0x39/0x40
<4> [<c0474128>] shrink_dcache_for_umount+0x30/0x3d
<4> [<c0464ae8>] generic_shutdown_super+0x19/0xd3
<4> [<c0464bc2>] kill_block_super+0x20/0x32
<4> [<c0464c82>] deactivate_super+0x5d/0x6f
<4> [<c04775f7>] mntput_no_expire+0x42/0x71
<4> [<c046a4ba>] path_release_on_umount+0x15/0x18
<4> [<c0478707>] sys_umount+0x1d3/0x207
<4> [<c0478748>] sys_oldumount+0xd/0xf
<4> [<c0402e57>] syscall_call+0x7/0xb
<0>Code: 02 00 00 8b 40 1c 85 d2 8b 00 c7 45 f0 00 00 00 00 74 06 8b 52 20 89 
55 f0 57 50 56 51 ff 75 f0 53 68 d5 75 61 c0 e8 a1 33 fa ff <0f> 0b 67 02 c9 75 
61 c0 83 c4 1c 8b 73 3c 39 de 75 04 31 f6 eb 
<0>EIP: [<c0473678>] shrink_dcache_for_umount_subtree+0x146/0x1d6 SS:ESP 
0068:f7a43eb4
Comment 1 Dave Jones 2006-09-17 01:34:06 EDT

*** This bug has been marked as a duplicate of 206036 ***

Note You need to log in before you can comment on or make changes to this bug.