This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 206545 - Eclipse crashes on start
Eclipse crashes on start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-14 19:42 EDT by Horst H. von Brand
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-15 12:38:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2006-09-14 19:42:31 EDT
Description of problem:
Eclise starts it's banner, but then crashes when around 90% through

Version-Release number of selected component (if applicable):
eclipse-platform-3.2.0-5.fc6

How reproducible:
Always

Steps to Reproduce:
1. Start eclipse via Applications --> Programming --> Eclipse
2.
3.
  
Actual results:
Window showing:
JVM terminated. Exit code=127
/usr/bin/java
-jar startup.jar
-os linux
-ws gtk
-arch x86
-launcher /usr/bin/eclipse
-name Eclipse
-showsplash 600
-exitdata 8800d
-vm /usr/bin/java
-vmargs
-jar startup.jar 

/usr/bin/java comes from java-1.4.2-gcj-compat-1.4.2.0-40jpp.108

Expected results:
Dunno. Never tried it before.

Additional info:
Comment 1 Ben Konrath 2006-09-14 22:59:15 EDT
Can you run eclipse from the command line using the -consolelog flag and post
the out here. Thanks.
Comment 2 Horst H. von Brand 2006-09-15 09:55:05 EDT
[vonbrand@laptop13 ~]$ eclipse --consolelog
/usr/bin/java: symbol lookup error:
/usr/share/eclipse/configuration/org.eclipse.osgi/bundles/29/1/.cp/libswt-mozilla-gtk-3232.so:
undefined symbol: NS_StringContainerInit2
Comment 3 Andrew Overholt 2006-09-15 09:57:34 EDT
(In reply to comment #2)
/usr/share/eclipse/configuration/org.eclipse.osgi/bundles/29/1/.cp/libswt-mozilla-gtk-3232.so:
> undefined symbol: NS_StringContainerInit2

yum remove mozilla

Also, you *may* need to rm -rf ~/.eclipse afterwards due to .so caching.
Comment 4 Horst H. von Brand 2006-09-15 12:37:20 EDT
Yup, removing mozilla fixed this.
Comment 5 Ben Konrath 2006-09-15 12:38:54 EDT
Cool, closing bug.

Note You need to log in before you can comment on or make changes to this bug.