Bug 206565 - Issues with RAID and Anaconda
Issues with RAID and Anaconda
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-14 22:34 EDT by Brian Topping
Modified: 2008-04-09 20:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 20:54:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Topping 2006-09-14 22:34:27 EDT
I just downloaded Test3 DVD from torrent (and am letting it seed with 2mbps+
upload :).  I'm seeing several problems on my installation.  This is the second
of them.  I'm doing this from memory after a phone call, so I might have
forgotten some of the details.

The machine I was trying to install fc6 on has two Promise controllers, each
with four SATA drives (one card with four 250GB and the other with four 400GB).
 Because the drives have data on them, I can't erase root, but I can erase /boot
and swap.  The set of 400GB drives has md0 which is 100GB mirrored across all
four disks and md1 which is the remainder in a RAID5.  The set of 250GB drives
has a single partition each, with md2 running RAID5 across them.  md1 and md2
are using lvm to combine into a single larger drive for root.

Under fc4, this worked fine.  Because /boot was mirrored across four disks and
the MDR duplicated to all four, a failure of sda could be rectified with a cable
swap.  md0 and md1 would be compromised, but the drive could be replaced and the
machine still able to boot to heal the arrays.

After an update of the very stable fc4 install on there went bad last week, I
was forced to consider what I wanted to upgrade to.  fc5 had the same problem as
fc6, but since I was only a day or two out for test3, I thought I would give it
a shot.  No luck.

So the regression is that fc4 could handle this configuration just fine from
anaconda (but did require manual initrd work), fc5 could not handle the
installation and would hang at "installing boot loader", and fc6 anaconda does
an emergency shutdown of the machine.

Please contact me if there is anything I can do to assist.  I am located in
Oakland, CA and am happy to work with someone local if we can get this bug resolved.
Comment 1 Matthew Miller 2007-04-06 12:58:07 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 2 Brian Topping 2007-04-06 14:28:42 EDT
I don't think it ever really worked after FC4, but I sold four of the eight
disks and don't have them to test with.

This is probably related to bad initRD and/or BIOS ordering v. kernel ordering
of drives as a part of the install.
Comment 3 Bug Zapper 2008-04-03 23:44:02 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 4 Brian Topping 2008-04-03 23:53:01 EDT
Well, like I said, it's going to take someone with two controllers and enough
disks on a mobo that has a BIOS ordering that is opposite to Linux to test this.
 I probably don't even have that mobo around any more, even though I had it
sitting there unused for a while.

I got the support I paid for, no missed expectations there :-)

Cheers!
Comment 5 John Poelstra 2008-04-09 20:54:09 EDT
Thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.