Bug 20657 - Printtool freezes desktop
Printtool freezes desktop
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i686 Linux
high Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-10 15:17 EST by amitabha
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 22:32:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description amitabha 2000-11-10 15:17:05 EST
I have a Canon BJC 2000 which works perfectly with
Windows. I am running RH 6.2 on an AMD Athlon.
Whenever I try to run printtool, it freezes the machine
so I have to poweroff to reboot (the power switch on the
machine does not work). 

 When it reboots, I am asked to repair the file system
with fsck since it finds unattached inodes.  

 I checked /etc/printcap and it contains unreadable characters.
I delete that. 

 This happens every time, so you should be able to reproduce it.
I tried all the different canon drivers - for BJC610 and up.
There does not seem to be a native driver for the 2000
(there does seem to be for the 4000 series). 

 Can you suggest what to do ? I have installed the latest lpr update
from RedHat.  This is urgent since I work with tetex and would
like to be able to print out my files rather than go through the
process of writing to the DOS partition and printing from Windows.

Thanks. 

By the way, echo "Hello world" > /dev/lp0  also freezes up
the machine.
Comment 1 amitabha 2000-11-20 04:16:34 EST
Ok - I did some more testing. I have attached some
more relevant information below.

 The printer works fine from Windows so I don't expect
that it is a problem with the printer.

Can someone please help me figure this out ?

My /proc/interrupts is
  0:     496708          XT-PIC  timer
  1:      19275          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  4:    2737000          XT-PIC  serial
  8:          1          XT-PIC  rtc
 10:     148404          XT-PIC  VIA 82C686A
 12:     183872          XT-PIC  PS/2 Mouse
 13:          1          XT-PIC  fpu
 14:    1004425          XT-PIC  ide0
 15:       9451          XT-PIC  ide1
NMI:          0


My /proc/ioports is the following:
0000-001f : dma1
0020-003f : pic1
0040-005f : timer
0060-006f : keyboard
0070-007f : rtc
0080-008f : dma page reg
00a0-00bf : pic2
00c0-00df : dma2
00f0-00ff : fpu
0170-0177 : ide1
01f0-01f7 : ide0
0320-0321 : VIA 82C686A - MPU401
0376-0376 : ide1
03c0-03df : vga+
03f6-03f6 : ide0
03f8-03ff : serial(auto)
d000-d007 : ide0
d008-d00f : ide1
dc00-dcff : VIA 82C686A - AC'97
e400-e403 : VIA 82C686A - MPU401 config


Comment 2 Crutcher Dunnavant 2001-03-29 11:29:53 EST
if echoing into the lp device freezes the machine, you have some sort of kernel
problems.
Comment 3 Tim Waugh 2001-05-28 14:17:56 EDT
Does this still happen?  Do you have any PCI or ISA parallel port cards in the 
machine?
Comment 4 Alan Cox 2002-12-14 22:32:43 EST
No replies

Note You need to log in before you can comment on or make changes to this bug.