Bug 206580 - Unable to "make rpm" for kernel-2.6.17-1.2187_FC5.src.rpm
Unable to "make rpm" for kernel-2.6.17-1.2187_FC5.src.rpm
Status: CLOSED DUPLICATE of bug 126342
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-15 00:31 EDT by Mace Moneta
Modified: 2015-01-04 17:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-16 23:07:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
spec file from an unmodified, failing 'make rpm' (1.16 KB, text/plain)
2006-09-16 12:10 EDT, Mace Moneta
no flags Details

  None (edit)
Description Mace Moneta 2006-09-15 00:31:38 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. wget
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/5/SRPMS/kernel-2.6.17-1.2187_FC5.src.rpm
2. rpm -Uvh kernel-2.6.17-1.2187_FC5.src.rpm
3. cd /usr/src/redhat/SPECS/
4. rpmbuild -bp --target=i686 kernel-2.6.spec
5. cd /usr/src/redhat/BUILD/kernel-*/linux-*/
6. cp -v -f configs/kernel-2.6.*-i686.config ./.config
7. Update Makefile "EXTRAVERSION"
8. make oldconfig && nice make clean && nice make xconfig
9. Select Pentium-4 processor, save, quit
10. Apply the latest toshiba_acpi patch
(http://memebeam.org/free-software/toshiba_acpi/?C=M;O=D)

 cd drivers/acpi/
 patch < /usr/local/src/toshiba_acpi-dev_toshiba_test5-linux_2.6.17.patch
 cd ../../

11. make rpm


Actual results:

# make rpm
make clean
set -e; cd ..; ln -sf /usr/src/redhat/BUILD/kernel-2.6.17/linux-2.6.17.i686
kernel-2.6.171.2187_FC5mm
set -e; cd ..; tar -cz --exclude SCCS --exclude BitKeeper --exclude .svn
--exclude CVS --exclude .pc --exclude .hg --exclude .git -f
kernel-2.6.171.2187_FC5mm.tar.gz kernel-2.6.171.2187_FC5mm/.
set -e; cd ..; rm kernel-2.6.171.2187_FC5mm
set -e; \
/bin/sh /usr/src/redhat/BUILD/kernel-2.6.17/linux-2.6.17.i686/scripts/mkversion
> /usr/src/redhat/BUILD/kernel-2.6.17/linux-2.6.17.i686/.tmp_version
set -e; \
mv -f /usr/src/redhat/BUILD/kernel-2.6.17/linux-2.6.17.i686/.tmp_version
/usr/src/redhat/BUILD/kernel-2.6.17/linux-2.6.17.i686/.version
rpmbuild --target i386 -ta ../kernel-2.6.171.2187_FC5mm.tar.gz
Building target platforms: i386
Building for target i386
error: Name field must be present in package: (main package)
error: Version field must be present in package: (main package)
error: Release field must be present in package: (main package)
error: Summary field must be present in package: (main package)
error: Group field must be present in package: (main package)
error: License field must be present in package: (main package)
make[1]: *** [rpm] Error 1
make: *** [rpm] Error 2


Expected results:

Normal build

Additional info:
Comment 1 Mace Moneta 2006-09-15 00:41:38 EDT
Sorry, forgot to fill these in, though they are obvious:


Description of problem:

Trying to "make rpm" on the new kernel source fails.  

Version-Release number of selected component (if applicable):

kernel-2.6.17-1.2187_FC5.src.rpm
Comment 2 Mace Moneta 2006-09-16 12:10:03 EDT
Created attachment 136436 [details]
spec file from an unmodified, failing 'make rpm'

I've confirmed that this occurs even with a "vanilla" build sequence:

1. wget
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/5/SRPMS/kernel-2.6.17-1.2187_FC5.src.rpm

2. rpm -ivh kernel-2.6.17-1.2187_FC5.src.rpm
3. cd /usr/src/redhat/SPECS/
4. rpmbuild -bp --target=i686 kernel-2.6.spec
5. cd /usr/src/redhat/BUILD/kernel-2.6.17/linux-2.6.17.i686/
6. cp configs/kernel-2.6.17-i686.config ./.config
7. make oldconfig
8. make clean
9. make rpm

/bin/sh
/usr/src/redhat/BUILD/kernel-2.6.17/linux-2.6.17.i686/scripts/package/mkspec >
/usr/src/redhat/BUILD/kernel-2.6.17/linux-2.6.17.i686/kernel.spec
make clean
set -e; cd ..; ln -sf /usr/src/redhat/BUILD/kernel-2.6.17/linux-2.6.17.i686
kernel-2.6.17prep
set -e; cd ..; tar -cz --exclude SCCS --exclude BitKeeper --exclude .svn
--exclude CVS --exclude .pc --exclude .hg --exclude .git -f
kernel-2.6.17prep.tar.gz kernel-2.6.17prep/.
set -e; cd ..; rm kernel-2.6.17prep
set -e; \
/bin/sh /usr/src/redhat/BUILD/kernel-2.6.17/linux-2.6.17.i686/scripts/mkversion
> /usr/src/redhat/BUILD/kernel-2.6.17/linux-2.6.17.i686/.tmp_version
set -e; \
mv -f /usr/src/redhat/BUILD/kernel-2.6.17/linux-2.6.17.i686/.tmp_version
/usr/src/redhat/BUILD/kernel-2.6.17/linux-2.6.17.i686/.version
rpmbuild --target i386 -ta ../kernel-2.6.17prep.tar.gz
Building target platforms: i386
Building for target i386
error: Name field must be present in package: (main package)
error: Version field must be present in package: (main package)
error: Release field must be present in package: (main package)
error: Summary field must be present in package: (main package)
error: Group field must be present in package: (main package)
error: License field must be present in package: (main package)
make[1]: *** [rpm] Error 1
make: *** [rpm] Error 2


While it appears that the spec file is not in the tar file, it is:

tar xvzf kernel-2.6.17prep.tar.gz kernel-2.6.17prep/./kernel.spec

The kernel.spec file is attached.
Comment 3 Dave Jones 2006-09-16 23:07:49 EDT
make rpm is the wrong target to be using.
use rpmbuild.


*** This bug has been marked as a duplicate of 126342 ***

Note You need to log in before you can comment on or make changes to this bug.