Bug 206631 - Evolution 2.8 crashes on startup
Evolution 2.8 crashes on startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution-connector (Show other bugs)
6
All Linux
low Severity medium
: ---
: ---
Assigned To: Milan Crha
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-15 08:51 EDT by John D. Ramsdell
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 11:55:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bug Buddy output (1.67 KB, text/plain)
2006-09-15 08:51 EDT, John D. Ramsdell
no flags Details
Goo's fedora core repo file (840 bytes, text/plain)
2006-09-22 15:56 EDT, John D. Ramsdell
no flags Details
gdb output running evolution (47.17 KB, text/plain)
2006-10-12 12:14 EDT, Dave Strickland
no flags Details
Goo's GDB backtrace output on evolution (2.11 KB, text/plain)
2006-10-12 12:50 EDT, John D. Ramsdell
no flags Details
Fresh FC 6 Bug Buddy output on evolution (15.88 KB, text/plain)
2006-10-25 15:18 EDT, John D. Ramsdell
no flags Details
Fresh FC6 Bug Buddy output with debuginfo installed (15.40 KB, text/plain)
2006-10-25 15:44 EDT, John D. Ramsdell
no flags Details
Output to shell when evolution crashes (458 bytes, text/plain)
2006-10-25 15:46 EDT, John D. Ramsdell
no flags Details
GDB output with debuginfo installed on fresh FC6 install on goo (6.80 KB, text/plain)
2006-10-27 07:22 EDT, John D. Ramsdell
no flags Details
Evolution 2.10.1 bug buddy output (No debug symbols) (15.14 KB, text/plain)
2007-06-12 13:36 EDT, John D. Ramsdell
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 381548 None None None Never

  None (edit)
Description John D. Ramsdell 2006-09-15 08:51:51 EDT
Description of problem:

Evolution 2.6 crashes on startup (See enclosed Bug Buddy output for more details.)

Version-Release number of selected component (if applicable):

2.6

How reproducible:

Start application



Steps to Reproduce:
1. start application.
  
Actual results:

crash

Expected results:

no crash


Additional info: See attached Bug Buddy output for more information.
Comment 1 John D. Ramsdell 2006-09-15 08:51:51 EDT
Created attachment 136353 [details]
Bug Buddy output
Comment 2 Matthew Barnes 2006-09-21 15:30:55 EDT
Thanks for the bug report.

Can you please make sure you have the following packages installed, and then
post a full backtrace the next time you see the crash?  Also make sure that your
Fedora Core system is fully up-to-date.

evolution-debuginfo
evolution-data-server-debuginfo
libsoup-debuginfo
Comment 3 John D. Ramsdell 2006-09-22 09:14:30 EDT
I tried to intall the three debug packages with yum, but found no match.  So I
went to http://download.fedora.redhat.com/pub/fedora/linux/core/5/i386/debug/,
and downloaded the debuginfo rpm's listed above, and also the one for
evolution-connector.  When I started evolution in gdb, here is what it said:

[ramsdell@goo ~]$ gdb evolution
GNU gdb Red Hat Linux (6.3.0.0-1.134.fc5rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
warning: the debug information found in
"/usr/lib/debug//usr/bin/evolution-2.6.debug" does not match
"/usr/bin/evolution" (CRC mismatch).


(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".

(gdb) [ramsdell@goo ~]$

and, of course, the debug run produced no more useful information.

I have more bad news.  Someone came into my office two days ago, with a laptop
that cried for Linux, so yesterday, I took out my FC5 disks, installed with just
the office automation and developer features, installed emacs and evolution
connecter, and the did a yum update.  This laptop's version of evolution also
crashes.  It's not something funny about a long sequence of yum updates that
causes this problem.

John
Comment 4 Matthew Barnes 2006-09-22 10:17:31 EDT
John, can you please post exactly what versions of the evolution packages you're
using?  Here's the what you *should* have on a fully up-to-date Fedora Core 5:

$ rpm -q evolution evolution-data-server evolution-connector
evolution-2.6.3-1.fc5.5
evolution-data-server-1.6.3-1.fc5.2
evolution-connector-2.6.3-1.fc5.1

The fact that you weren't able to install the debuginfo packages makes me
suspect there's something amiss in your yum configuration.
Comment 5 John D. Ramsdell 2006-09-22 11:36:51 EDT
[ramsdell@goo ~]$ rpm -q evolution evolution-connector evolution-data-server libsoup
evolution-2.6.3-1.fc5.5
evolution-connector-2.6.3-1.fc5.1
evolution-data-server-1.6.3-1.fc5.2
libsoup-2.2.96-1.fc5.1
[ramsdell@goo ~]$

I think I'm match your expectations exactly.  I'm trying to find and read my yum
configuration file now; however, please note that I have never modified it, and
I'm pretty sure no one else has.  To be on the safe side, I'll check file dates.
Comment 6 John D. Ramsdell 2006-09-22 11:38:04 EDT
[ramsdell@goo ~]$ rpm -q evolution evolution-connector evolution-data-server libsoup
evolution-2.6.3-1.fc5.5
evolution-connector-2.6.3-1.fc5.1
evolution-data-server-1.6.3-1.fc5.2
libsoup-2.2.96-1.fc5.1
[ramsdell@goo ~]$

I think I am matching your expectations exactly.  I'm trying to find and read my
yum configuration file now; however, please note that I have never modified it,
and I'm pretty sure no one else has.  To be on the safe side, I'll check the
file's date.
Comment 7 John D. Ramsdell 2006-09-22 11:49:04 EDT
This is the dates on the yum configuration files.  This is also what I see on
the freshly installed machine.  I didn't see anything odd when I looked in some
of the files too, but then, I'm not a yum expert.


[ramsdell@goo etc]$ ls -l yum.conf yum.repos.d
-rw-r--r-- 1 root root  285 Apr 26 15:29 yum.conf

yum.repos.d:
total 56
-rw-r--r-- 1 root root  840 Mar 14  2006 fedora-core.repo
-rw-r--r-- 1 root root 1549 Mar 14  2006 fedora-development.repo
-rw-r--r-- 1 root root  780 Mar 14  2006 fedora-extras-development.repo
-rw-r--r-- 1 root root  763 Mar 14  2006 fedora-extras.repo
-rw-r--r-- 1 root root  486 Mar 14  2006 fedora-legacy.repo
-rw-r--r-- 1 root root  790 Mar 14  2006 fedora-updates.repo
-rw-r--r-- 1 root root  865 Mar 14  2006 fedora-updates-testing.repo
[ramsdell@goo etc]$ 
Comment 8 John D. Ramsdell 2006-09-22 11:52:46 EDT
If this helps, I uninstalled evolution connector, and I found that I still have
the same problem.  I have reinstalled it, so that future reports match the
environment on which the first bug report was filed.
Comment 9 Matthew Barnes 2006-09-22 14:07:53 EDT
Hmm, it might be that your debuginfo repository is disabled.

Make sure you have a "enabled=1" line in the [core-debuginfo] stanza of
fedora-core.repo, and then try installing the debuginfo packages again if you
found that it was disabled.

If you can get the debuginfo packages installed, then do:

   $ gdb evolution
   ... welcome message ...
   (gdb) run
   ... wait for crash ...
   (gdb) thread apply all backtrace

And please attach the resulting backtrace.
Comment 10 John D. Ramsdell 2006-09-22 14:43:54 EDT
You're not going to believe this.  As you figured out, fedora-core.repo had
enabled=0 in the [core-debuginfo] stanza.  I changed this setting, removed the
debuginfo packages I installed manually, and then did the yum install you
originally requested. Everything looked good.

When I ran gdb on evolution, I once again found the debug information in
"/usr/lib/debug//usr/bin/evolution-2.6.debug" does not match
"/usr/bin/evolution" (CRC mismatch)!  Here is what rpm queries told me.

[ramsdell@goo ~]$ rpm -q evolution evolution-debuginfo
evolution-2.6.3-1.fc5.5
evolution-debuginfo-2.6.0-1
[ramsdell@goo ~]$ rpm -q evolution-data-server evolution-data-server-debuginfo
evolution-data-server-1.6.3-1.fc5.2
evolution-data-server-debuginfo-1.5.92-1
[ramsdell@goo ~]$ rpm -q evolution-connector evolution-connector-debuginfo
evolution-connector-2.6.3-1.fc5.1
evolution-connector-debuginfo-2.5.92-1
[ramsdell@goo ~]$ rpm -q libsoup libsoup-debuginfo
libsoup-2.2.96-1.fc5.1
libsoup-debuginfo-2.2.91-1
[ramsdell@goo ~]$
Comment 11 Matthew Barnes 2006-09-22 14:48:50 EDT
Can you post the contents of your fedora-core.repo file?
Comment 12 John D. Ramsdell 2006-09-22 15:56:47 EDT
Created attachment 136971 [details]
Goo's fedora core repo file
Comment 13 Dave Strickland 2006-10-12 12:14:24 EDT
Created attachment 138342 [details]
gdb output running evolution
Comment 14 Dave Strickland 2006-10-12 12:15:29 EDT
I've been having the exact same problem on all three of my FC5 systems. I just
want to add that 

(1) evolution is only crashing when you try to use the mail part, e.g. I can
successfully start evolution with "evolution -c calendar" and it doesn't crash.
Its only when I try to change the View->Window->Mail that it'll crash.

(2) I always get a bunch of command line warnings from camel when it crashes,
one for each mail sub-folder I have, e.g. 

(evolution-2.6:9711): camel-WARNING **: Could not save object state file to
'/home/dks/.evolution/mail/local/.#durham.cmeta': Too many open files

(evolution-2.6:9711): camel-local-provider-WARNING **: Could not open/create
index file: Too many open files: indexing not performed

I've attached part of a gdb log created using the method described in comment
#9. The interesting part is after all the camel warnings.
Comment 15 John D. Ramsdell 2006-10-12 12:50:13 EDT
Created attachment 138343 [details]
Goo's GDB backtrace output on evolution

I never did get the debugging symbols loaded for Evolution, but here is the
backtraces without the symbols.
Comment 16 Matthew Barnes 2006-10-25 12:56:06 EDT
As of yesterday, Evolution 2.6 is no longer supported in Fedora Core 5.
Can you please try again with Evolution 2.8 in Fedora Core 6?
Comment 17 John D. Ramsdell 2006-10-25 15:18:47 EDT
Created attachment 139386 [details]
Fresh FC 6 Bug Buddy output on evolution
Comment 18 John D. Ramsdell 2006-10-25 15:22:24 EDT
I created fresh FC 6 install disks this morning.  I installed FC 6 after wiping
my disk clean.  I installed evolution-connector, and then started evolution up.
 After entering my username and OWA URL, I then entered my password for
authentication.  Bug Buddy popped up telling me the calendaring tool crashed.  I
have attached its output.
Comment 19 Matthew Barnes 2006-10-25 15:25:05 EDT
Changing component to evolution-connector.
Comment 20 Matthew Barnes 2006-10-25 15:28:00 EDT
Please install the following "debuginfo" packages on your Fedora Core 6 machine
and post a new stack trace with debugging symbols.

evolution-debuginfo
evolution-data-server-debuginfo
evolution-connector-debuginfo
libsoup-debuginfo
Comment 21 John D. Ramsdell 2006-10-25 15:44:58 EDT
Created attachment 139396 [details]
Fresh FC6 Bug Buddy output with debuginfo installed
Comment 22 John D. Ramsdell 2006-10-25 15:46:19 EDT
Created attachment 139397 [details]
Output to shell when evolution crashes
Comment 23 John D. Ramsdell 2006-10-27 07:22:57 EDT
Created attachment 139569 [details]
GDB output with debuginfo installed on fresh FC6 install on goo
Comment 24 John D. Ramsdell 2006-11-02 09:26:00 EST
I did a yum update this morning and got new versions of various parts of
evolution.  It still crashes.  I notice the updates were not accompanyied by new
versions of their debuginfo, and I can nolonger obtain verbose backtraces.
Comment 25 Matthew Barnes 2006-11-02 10:13:47 EST
You may need to explicitly update the debuginfo packages.

# yum update evolution-debuginfo evolution-data-server-debuginfo ...
Comment 26 John D. Ramsdell 2006-11-02 11:36:51 EST
I cannot seem to find the debug info.  I use hpyum which just sets http_proxy
and then calls yum.  Here is what happens.

[root@goo ramsdell]# ./hpyum update evolution-debuginfo
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
core                      100% |=========================| 1.1 kB    00:00
updates                   100% |=========================| 1.2 kB    00:00
core-debuginfo            100% |=========================| 1.1 kB    00:00
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
Could not find update match for evolution-debuginfo
No Packages marked for Update/Obsoletion
[root@goo ramsdell]#
sh-2.05b$
Comment 27 John D. Ramsdell 2006-11-02 15:41:56 EST
I figured it out.  You have to enable updates-debuginfo in fedora-updates.repo.
 I had enabled core-debuginfo in fedore-core-repo.  The change allows me do
download the required debuginfo.
Comment 28 John D. Ramsdell 2007-01-30 15:08:09 EST
I have new information about this bug.  I'm pretty sure the problem is in
evolution-data-server-x.x.x/servers/exchange/lib/e2k-context.c.  Near line 585,
we have:

 	value = xmlGetProp (node, "action");
 	if (!value)
 		goto failed;

After this point, I suspect the code assumes that the length of the string in
value is not zero, but at our site, it is.  Our Exchange admins changed the OWA
interface, causing the value to be an empty string, so it is not surprising
Evolution fails to connect.  The bug is that a zero length string causes a
segmentation violation.

Now for truth in advertising--I haven't actually verified this is the error
myself.  I looked at a patch another person within my company used to get
Evolution working for him.  From that patch, I'm guessing the fix is to replace
the if statement with this one:

        if (!value || !*value) goto failed;
Comment 29 Milan Crha 2007-06-07 07:44:00 EDT
Hi John, I discuss this with upstream developer and he said that that could be
helpful if you could send him an exchange debug "log". You need only run this
command:
export E2K_DEBUG=4 evolution
and "try" to crash it. There should be more debug messages on the console, with
this command, simply place them here and I'll give it him. Or you could place it
to that upstream bug [1] either. Thanks a lot.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=381548
Comment 30 John D. Ramsdell 2007-06-12 13:34:20 EDT
I assume you meant "E2K_DEBUG=4 evolution".  First thing, let me point out that
I just updated to Fedora 7.  Second, I haven't installed the debug symbols yet,
but I have included the bug buddy output along with exchange debug log.  I'll
install the symbols if the log data is not sufficient.

[ramsdell@goo ~]$ E2K_DEBUG=4 evolution
CalDAV Eplugin starting up ...
(evolution:11239): e-data-server-ui-DEBUG: ep_msg_send: in main thread? 1
(evolution:11239): e-data-server-ui-DEBUG: ep_msg_send: in main thread? 1
(evolution:11239): e-data-server-ui-DEBUG: ep_msg_send: in main thread? 1
GET  HTTP/1.1
E2k-Debug: 0x97f9528 @ 1181668816
Host: imc.mitre.org
Accept-Language: en-US, en
Authorization: NTLM TlRMTVNTUAABAAAABoIAAAAAAAAAAAAAAAAAAAAAAAAAAAAAMAAAAAAAAAAwAAAA
User-Agent: Evolution/1.10.1

500 Internal Server Error
E2k-Debug: 0x97f9528 @ 1181668816
Date: Tue, 12 Jun 2007 17:20:16 GMT
X-Powered-By: ASP.NET
Server: Microsoft-IIS/6.0
Connection: close
Content-Length: 100
Content-Type: text/html

GET /exchange/ HTTP/1.1
E2k-Debug: 0x97f9810 @ 1181668816
Host: imc.mitre.org
Accept-Language: en-US, en
Authorization: NTLM TlRMTVNTUAABAAAABoIAAAAAAAAAAAAAAAAAAAAAAAAAAAAAMAAAAAAAAAAwAAAA
User-Agent: Evolution/1.10.1

302 Moved Temporarily
E2k-Debug: 0x97f9810 @ 1181668816
Set-Cookie: sessionid=; path=/; expires=Thu, 01-Jan-1970 00:00:00 GMT
Set-Cookie: cadata=; path=/; expires=Thu, 01-Jan-1970 00:00:00 GMT
Location:
https://imc.mitre.org/exchweb/bin/auth/owalogon.asp?url=https://imc.mitre.org/exchange/&reason=0
Connection: close
Content-Length: 0

GET /exchange/ HTTP/1.1
E2k-Debug: 0x97f9768 @ 1181668816
Host: imc.mitre.org
Authorization: NTLM TlRMTVNTUAABAAAABoIAAAAAAAAAAAAAAAAAAAAAAAAAAAAAMAAAAAAAAAAwAAAA
User-Agent: Evolution/1.10.1

302 Moved Temporarily
E2k-Debug: 0x97f9768 @ 1181668816
Set-Cookie: sessionid=; path=/; expires=Thu, 01-Jan-1970 00:00:00 GMT
Set-Cookie: cadata=; path=/; expires=Thu, 01-Jan-1970 00:00:00 GMT
Location:
https://imc.mitre.org/exchweb/bin/auth/owalogon.asp?url=https://imc.mitre.org/exchange/&reason=0
Connection: close
Content-Length: 0

GET /exchweb/bin/auth/owalogon.asp?url=https://imc.mitre.org/exchange/&reason=0
HTTP/1.1
E2k-Debug: 0x97f9768 @ 1181668816 [restarted]
Host: imc.mitre.org
Authorization: NTLM TlRMTVNTUAABAAAABoIAAAAAAAAAAAAAAAAAAAAAAAAAAAAAMAAAAAAAAAAwAAAA
User-Agent: Evolution/1.10.1

200 OK
E2k-Debug: 0x97f9768 @ 1181668816
Date: Tue, 12 Jun 2007 17:20:16 GMT
X-Powered-By: ASP.NET
Expires: Tue, 12 Jun 2007 17:19:16 GMT
Server: Microsoft-IIS/6.0
Cache-Control: no-cache
Content-Length: 11141
Content-Type: text/html


(evolution:11239): libsoup-CRITICAL **: soup_message_set_request: assertion
`SOUP_IS_MESSAGE (msg)' failed

(evolution:11239): libsoup-CRITICAL **: soup_message_set_flags: assertion
`SOUP_IS_MESSAGE (msg)' failed

(evolution:11239): libsoup-CRITICAL **: soup_session_send_message: assertion
`SOUP_IS_MESSAGE (msg)' failed


[ramsdell@goo ~]$ evolution --version
GNOME evolution 2.10.1
[ramsdell@goo ~]$ 



Comment 31 John D. Ramsdell 2007-06-12 13:36:37 EDT
Created attachment 156811 [details]
Evolution 2.10.1 bug buddy output (No debug symbols)
Comment 32 Milan Crha 2007-06-12 14:01:48 EDT
Thanks John, I will write it to upstream bug (and developer) and let you know.
Comment 33 Milan Crha 2007-07-19 12:22:50 EDT
I'm so sorry I write you so late, I have a discussion with upstream maintainer
and I got your patch and attached it to the upstream bug, when they will accept
it, we will push this to fedora too.
Comment 34 Matthew Barnes 2007-10-05 11:55:33 EDT
Upstream bug is marked FIXED so I'm closing this one.

Note You need to log in before you can comment on or make changes to this bug.