Bug 206643 - intel(4) whitelist: Dell Inspiron 700m
intel(4) whitelist: Dell Inspiron 700m
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-15 09:52 EDT by Mark Patton
Modified: 2008-02-14 10:48 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-14 10:48:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X.log from anaconda (64.03 KB, text/plain)
2006-09-15 15:55 EDT, Mark Patton
no flags Details
Currently used xorg.conf (886 bytes, application/octet-stream)
2007-05-30 12:12 EDT, Mark Patton
no flags Details
X log (42.73 KB, text/plain)
2007-05-30 12:14 EDT, Mark Patton
no flags Details
Another X log (49.78 KB, application/octet-stream)
2007-05-30 13:04 EDT, Mark Patton
no flags Details
X log after autodetect (70.23 KB, text/plain)
2007-05-30 13:13 EDT, Mark Patton
no flags Details

  None (edit)
Description Mark Patton 2006-09-15 09:52:28 EDT
Description of problem:

During installation of test3 on a Dell Inspiron 700m,
the graphical install screen is offcenter (to the top left) using only
two-thirds of the screen.

Version-Release number of selected component (if applicable):


How reproducible:

Very.

Steps to Reproduce:
1. Boot from CD from installation.
  
Actual results:

Display not full screen.

Expected results:

Display full screen.

Additional info:

The integrated graphics card (intel) was detected during boot. The screen
resolution is 1280x800.
Comment 1 Adam Jackson 2006-09-15 15:33:14 EDT
I think this is the no-EDID issue as fixed in xorg-x11-drv-i810-1.6.5-6 and
later.  Can you attach the X log from a failed X session?
Comment 2 Mark Patton 2006-09-15 15:55:59 EDT
Created attachment 136387 [details]
X.log from anaconda

I grabbed the X.log that anaconda writes during installation.
Comment 3 Adam Jackson 2006-09-15 19:06:58 EDT
Ah, different (and very old) issue.  The native panel size is 1280x800, but the
VESA BIOS contains no 1280x800 modes; since the 'i810' driver can only set those
modes listed in the BIOS, it simply picks the closest match instead.

After install, if you change Driver "i810" to Driver "intel" in xorg.conf, do
you get the native panel size?  If so I can add your hardware to the whitelist
for the new driver.
Comment 4 Mark Patton 2006-09-16 08:58:44 EDT
I switched the driver to Intel and removed the call to 855resolution in my
initscripts. After a reboot, X ran fine. It's great to see I don't have to
bother with 855resolution any more.
Comment 5 Adam Jackson 2006-10-04 11:27:20 EDT
Updating summary.  FC6 is in deep freeze right now, but we'll add this hardware
to the whitelist for FC6 updates.
Comment 6 Mark Patton 2007-03-05 14:05:39 EST
The same issue persists in FC7 test 2. Changing the driver to intel, fixes the
problem.
Comment 7 Matthew Miller 2007-04-06 15:37:30 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 8 Mark Patton 2007-05-07 16:03:32 EDT
The same problem is in FC7 test 4.
Comment 9 Matěj Cepl 2007-05-29 18:57:18 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 10 Mark Patton 2007-05-30 12:12:34 EDT
Created attachment 155707 [details]
Currently used xorg.conf
Comment 11 Mark Patton 2007-05-30 12:14:03 EDT
Created attachment 155708 [details]
X log
Comment 12 Mark Patton 2007-05-30 13:04:55 EDT
Created attachment 155710 [details]
Another X log
Comment 13 Mark Patton 2007-05-30 13:13:41 EDT
Created attachment 155711 [details]
X log after autodetect

Here is the X log created after xorg.conf is removed and the laptop restarted.
The screen came up in 1024x768 resolution.

Also to be clear, the original problem with the boot screen during installation
not being fullscreen is fixed. The remaining issue is just having X be
correctly autoconfigured.
Comment 14 zuka 2007-06-06 21:39:19 EDT
HIi, I've got 700m. Just installed FC7 (fresh install) and it defaulted to 
1024x768 with the i810 driver. I switched to the intel driver and it works with 
1280x800 but it has locked up about 3 times today. Mouse freezes and keyboard 
is unresponsive. It's quite random when it freezes. I have not tried installing 
any 3rd party drivers. 1st time it froze I tried playing a video. I changed the 
video output (mplayer) from xv to gl output and it didn't freeze after I did 
that but has frozen when I was installing something with pirut.
Comment 15 Adam Jackson 2007-08-14 14:28:26 EDT
Please update to xorg-x11-drv-intel 2.1.1 and see if this is still an issue for you.
Comment 16 Mark Patton 2007-08-15 14:52:38 EDT
I don't see a package named xorg-x11-drv-intel available. Is it in a separate
testing repositoru?

Also, I experience the same problems zaku describes. In particular making xine
from freshrpms fullscreen while playing a video causes the laptop to freeze. Of
course this could be freshrpms fault.
Comment 18 Jesse Barnes 2008-01-10 16:41:55 EST
Sounds like the intel driver gives you the modes you want but has other Xv 
related problems (which may be fixed now).  So this can probably be closed and 
other bugs filed for the Xv problems.
Comment 19 Adam Jackson 2008-02-14 10:48:36 EST
intel(4) everywhere in F9, closing.

Note You need to log in before you can comment on or make changes to this bug.