Bug 206644 - mysql-administrator segfaults when clicking on a user
Summary: mysql-administrator segfaults when clicking on a user
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mysql-gui-tools (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FE7Target
TreeView+ depends on / blocked
 
Reported: 2006-09-15 14:01 UTC by David Kovalsky
Modified: 2014-03-31 23:44 UTC (History)
2 users (show)

Fixed In Version: mysql-administrator-5.0r11-3.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-13 12:07:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Kovalsky 2006-09-15 14:01:59 UTC
Hit this issue when testing Fedora Core test3, build 20060912.2 and
fedora-extras-devel


Version-Release number of selected component (if applicable):
mysql-administrator-1.1.10-3.fc6
mysql-5.0.22-2.1


How reproducible:
always

Steps to Reproduce:
1. log on to a machine as root
2. `vncserver` on server, `vncviewer machine:display &` on client
3. `mysql-administrator &` in xterm through VNC (my desktop is gnome btw)
4. login to mysql server (localhost, 3306, root, $password)
5. select 'user administration'
6. right click on a user, select 'add host'
7. select localhost and pres enter -> segfault


Actual results:
segfault

Expected results:
does not segfault ;-)

Additional info:
### console output
[root@test1146 ~]# mysql-administrator &
[1] 5548
[root@test1146 ~]# /usr/bin/mysql-administrator: line 20:  5551 Segmentation
fault      $PRG-bin $*


### console output from another atempt
[root@test1146 ~]# mysql-administrator

** (mysql-administrator-bin:27924): CRITICAL **: void
MGFileBrowserList::get_row_object(const Gtk::TreeIter&, std::string&): assertion
`iter' failed

Gtk-ERROR **: file gtktreestore.c: line 505 (gtk_tree_store_get_path): assertion
failed: (G_NODE (iter->user_data)->parent != NULL)
aborting...
/usr/bin/mysql-administrator: line 20: 27924 Aborted                 $PRG-bin $*
[root@test1146 ~]# mysql-administrator

Gtk-ERROR **: file gtktreestore.c: line 505 (gtk_tree_store_get_path): assertion
failed: (G_NODE (iter->user_data)->parent != NULL)
aborting...
/usr/bin/mysql-administrator: line 20: 27941 Aborted                 $PRG-bin $*

Comment 1 Dennis Gilmore 2007-04-11 15:39:01 UTC
reassigning mysql-administrator bugs to mysql-gui-tools.

Please test with the new version just pushed.

Comment 2 David Kovalsky 2007-04-13 11:40:39 UTC
Seems fixed, does not segfault, no other issues found.

[root@hurt ~]# rpm -qa|grep mysql|sort
mysql-5.0.27-1.fc6
mysql-administrator-5.0r11-3.fc6
mysql-bench-5.0.27-1.fc6
mysql-gui-common-5.0r11-3.fc6
mysql-server-5.0.27-1.fc6
mysql-test-5.0.27-1.fc6

Note that I changed the version to FC6 since that's what I tested (was devel at
the time of reporting).


Note You need to log in before you can comment on or make changes to this bug.