Bug 206674 - amsn webcam libraries not found
amsn webcam libraries not found
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: amsn (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Sander Hoentjen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-15 12:42 EDT by Jos Vos
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-24 14:54:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for amsn.spec. (4.25 KB, patch)
2006-09-19 09:49 EDT, Jos Vos
no flags Details | Diff

  None (edit)
Description Jos Vos 2006-09-15 12:42:54 EDT
Description of problem:
It semms that the Fedora amsn does not detect webcams due to the fact that it
does not find some files at the right place (e.g. capture.so etc.).

Version-Release number of selected component (if applicable):
0.96-0.13.rc1.fc6 (but other versions probably have the same problem).

How reproducible:
Account->Preferences->Other->Configure Webcam and see if your webcam appears,

Additional info:
The RPM provides by the amsn team (0.96RC1-1.fc4) does work properly w.r.t. the
webcam.  I will post a patch for the Fedora RPM when I have made one (maybe next
Monday), it may be just adding a symlink to /usr/share/amsn or so.
Comment 1 Sander Hoentjen 2006-09-19 01:51:31 EDT
I looked and can't reproduce the problem.
Where is your capture.so located? Also in the same dir should be a file
pkgIndex.tcl, is it there?
Finally can you give me the result of:
echo "puts $::auto_path; exit" | wish
Comment 2 Jos Vos 2006-09-19 09:08:28 EDT
As per your spec file, capture.so is in /usr/lib/capture/capture.so.

The file pkgIndex.tcl is indeed in the same directory (/usr/lib/capture).

The output of your command is:
/usr/share/tcl8.4 /usr/share /usr/lib /usr/share/tcl8.4/tcllib-1.8 /usr/share/tk8.4

More to follow later...

P.S.
Apart from this problem, I'd suggest to put the lib stuff below /usr/lib/amsn,
not directly under /usr/lib, as now it pollutes /usr/lib too much with
package-specific stuff, IMHO.
Comment 3 Jos Vos 2006-09-19 09:48:03 EDT
Attached a patch to the spec file that works for me.  It basically adds symlinks
into /usr/lib for all the stuff moved from /usr/share/asmn.

Furthermore, I've put the lib stugg in /usr/lib/amsn and I removed the duplicate
slashes from the spec file (%{_datadir} etc already start with a slash), which
makes the patch look much bigger than the changes are.

Feel free to use my patches for future releases of amsn (or not).
Comment 4 Jos Vos 2006-09-19 09:49:14 EDT
Created attachment 136635 [details]
Patch for amsn.spec.
Comment 5 Sander Hoentjen 2006-09-20 02:58:15 EDT
Hmm if I see the output of your commands then it *should* work. Can you open up
amsn, then make sure the contactlist is the active windows, and press CTRL+S.
In the window that pops up please type in:
package require capture
let me know of the output.

About your patch:
I agree with the removal of the extra slashes in front of %{_datadir} etc.
in the files section you also changed:
-%{_datadir}/%{name}/
+%{_datadir}/%{name}
This I don't like because for style you can add the / to make clear it is a dir,
not a file.
The stuff in libdir is there since other programs can also use it, if they want.
Comment 6 Jos Vos 2006-09-20 04:28:23 EDT
Output of that command:

[10:30:20] Executing : package require capture
[10:30:20] 0.4

When I start "your" amsn from the command line, I see no output.  When I start
the version from the modified package, I see:

vid-probe: trying: v4l2...
open(/dev/video0): No such file or directory
open(/dev/video1): No such file or directory
open(/dev/video2): No such file or directory
open(/dev/video3): No such file or directory
vid-probe: trying: v4l...
open(/dev/video0): No such file or directory
open(/dev/video1): No such file or directory
open(/dev/video2): No such file or directory
open(/dev/video3): No such file or directory

(at this moment no webcam is plugged in, when I have one, it is found here).

So, there is a difference and this makes it not work for me...
Comment 7 Sander Hoentjen 2006-09-21 10:41:45 EDT
I'll have to look deeper into this, I prefer to solve this without symlinks.
There is no obvious reason it doesn't work that I can think of.
Comment 8 Sander Hoentjen 2006-11-04 08:08:07 EST
fixed in the latest build (0.96-2) can you please test and close the bug if it
works?
Comment 9 Sander Hoentjen 2006-11-24 14:54:36 EST
closing the bug, feel free to re-open if the issue still exists

Note You need to log in before you can comment on or make changes to this bug.