Bug 206678 - Deselect DHCP in Edit Interfaces (CD install) and can't go forward
Deselect DHCP in Edit Interfaces (CD install) and can't go forward
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-15 12:53 EDT by Robert Dowling
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 17:19:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Dowling 2006-09-15 12:53:02 EDT
Description of problem:

Want to install from CD and setup up network without DHCP,
so deselect it in Edit Interfaces eth0.

2 cases tried:

1) Want only IPv4 so deselect IPv6.  Put in IP / NM and [NEXT]
(unless the box IPv4 Address: ________ / ____ wants some other kind of input!)
and dialog insists we enter IPv6 IP / NP. "A value is required for field IPv6
address"

2) Try again, keeping IPv4 and IPv6 selected, enter IP/NP for IPv4, enter
bogus IP/NP for IPv6 (just a wild guess ::ffff:10.79.240.135 but nothing after
/), then Deselect IPv6 hoping it will
ignore values, and we get...

"An unhandled exception has occurred
Traceback (most recent call first):
  File "/usr/lib/anaconda/lw/network_gui.py", line 473, in editDevice
  if int(val) > 128 or int(val) < 0:
ValueError: invalid literal for int()
..."

3) Finally, leave both IPv4 and IPv6 selected, use a converter to generate an
equivalent IPv6 for my IPv4 (even though I know nothing about this!)  something
like this: 000:0000:0000:0000:0000:0000:0a4f:face/10
and it lets us go forward.

Version-Release number of selected component (if applicable):

FC6test3 CD's

How reproducible:

Every time

Steps to Reproduce:

1. On "Network Devices" page, click [Edit]
2. then Deselect [Use dynamic IP configuration (DHCP)]
3. Try one of two cases shown above
  
Actual results:


Expected results:


Additional info:
Comment 1 David Cantrell 2006-09-18 17:19:27 EDT
The _____ / _____ are to make the IP address input boxes look similar for IPv4
and IPv6.  It is IP address / prefix.

For IPv4, I accept a dotted-quad netmask or a CIDR prefix.  So the following
would be valid:

192.168.1.1 / 255.255.255.0
192.168.1.1 / 24

For IPv6, you can only enter a prefix value in the second field since there is
no netmask notation for IPv6.

I will add some labels.

I have corrected the input validation problems for manual configuration.  Thanks
for the report.

Note You need to log in before you can comment on or make changes to this bug.