Bug 2067108 - ath9k WiFi problem >5.16.14
Summary: ath9k WiFi problem >5.16.14
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2068272 2068350 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-03-23 10:31 UTC by FSA
Modified: 2022-03-30 01:28 UTC (History)
33 users (show)

Fixed In Version: kernel-5.16.18-100.fc34 kernel-5.16.18-200.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-30 01:11:26 UTC
Type: Bug


Attachments (Terms of Use)

Description FSA 2022-03-23 10:31:39 UTC
1. Wireless fails solidly after a bit of network and web activity; network pauses, connection drops. Restarts itself.

2. What is the Version-Release number of the kernel: 5.16.15 and 5.16.16

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 : 5.16.14 and later

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:
The network periodically goes down and recovers

03:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
	Subsystem: Lite-On Communications Inc Device 6628
	Kernel driver in use: ath9k
	Kernel modules: ath9k

...
мар 22 19:38:39 fsa-k75de kernel: ath: regdomain 0x8283 dynamically updated by country element
мар 22 19:39:06 fsa-k75de kernel: ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x02000020 DMADBG_7=0x00006100
мар 22 19:39:07 fsa-k75de kernel: wlp3s0: authenticate with xx:xx:xx:xx:xx:xx
мар 22 19:39:07 fsa-k75de kernel: wlp3s0: send auth to xx:xx:xx:xx:xx:xx (try 1/3)
мар 22 19:39:07 fsa-k75de kernel: wlp3s0: authenticated
мар 22 19:39:07 fsa-k75de kernel: wlp3s0: associate with xx:xx:xx:xx:xx:xx (try 1/3)
мар 22 19:39:07 fsa-k75de kernel: wlp3s0: RX AssocResp from xx:xx:xx:xx:xx:xx (capab=0x411 status=0 aid=2)
мар 22 19:39:07 fsa-k75de kernel: wlp3s0: associated
мар 22 19:39:07 fsa-k75de kernel: ath: EEPROM regdomain: 0x8283
мар 22 19:39:07 fsa-k75de kernel: ath: EEPROM indicates we should expect a country code
мар 22 19:39:07 fsa-k75de kernel: ath: doing EEPROM country->regdmn map search
мар 22 19:39:07 fsa-k75de kernel: ath: country maps to regdmn code: 0x3d
мар 22 19:39:07 fsa-k75de kernel: ath: Country alpha2 being used: RU
мар 22 19:39:07 fsa-k75de kernel: ath: Regpair used: 0x3d
мар 22 19:39:07 fsa-k75de kernel: ath: regdomain 0x8283 dynamically updated by country element
мар 22 19:49:08 fsa-k75de kernel: ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x02000020 DMADBG_7=0x00006100
мар 22 19:49:09 fsa-k75de kernel: wlp3s0: authenticate with xx:xx:xx:xx:xx:xx
мар 22 19:49:09 fsa-k75de kernel: wlp3s0: send auth to xx:xx:xx:xx:xx:xx (try 1/3)
мар 22 19:49:09 fsa-k75de kernel: wlp3s0: authenticated
мар 22 19:49:09 fsa-k75de kernel: wlp3s0: associate with xx:xx:xx:xx:xx:xx (try 1/3)
мар 22 19:49:09 fsa-k75de kernel: wlp3s0: RX AssocResp from xx:xx:xx:xx:xx:xx (capab=0x411 status=0 aid=2)
мар 22 19:49:09 fsa-k75de kernel: wlp3s0: associated
мар 22 19:49:09 fsa-k75de kernel: ath: EEPROM regdomain: 0x8283
мар 22 19:49:09 fsa-k75de kernel: ath: EEPROM indicates we should expect a country code
мар 22 19:49:09 fsa-k75de kernel: ath: doing EEPROM country->regdmn map search
мар 22 19:49:09 fsa-k75de kernel: ath: country maps to regdmn code: 0x3d
мар 22 19:49:09 fsa-k75de kernel: ath: Country alpha2 being used: RU
мар 22 19:49:09 fsa-k75de kernel: ath: Regpair used: 0x3d
мар 22 19:49:09 fsa-k75de kernel: ath: regdomain 0x8283 dynamically updated by country element
мар 22 19:49:29 fsa-k75de kernel: ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x02000020 DMADBG_7=0x00006100
мар 22 19:49:30 fsa-k75de kernel: wlp3s0: authenticate with xx:xx:xx:xx:xx:xx
мар 22 19:49:30 fsa-k75de kernel: wlp3s0: send auth to xx:xx:xx:xx:xx:xx (try 1/3)
...

Comment 1 jr.om 2022-03-23 13:15:22 UTC
So, it seems I have the exact same problem in "Qualcomm Atheros QCA9565 / AR9565" since Monday, and my outputs are pretty much the same except I don't get this message:

мар 22 19:49:29 fsa-k75de kernel: ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x02000020 DMADBG_7=0x00006100



dmesg output:
```
[qua mar 23 10:05:44 2022] wlp2s0: authenticate with xx:xx:xx:xx:xx:xx
[qua mar 23 10:05:44 2022] wlp2s0: send auth to xx:xx:xx:xx:xx:xx (try 1/3)
[qua mar 23 10:05:44 2022] wlp2s0: authenticated
[qua mar 23 10:05:44 2022] wlp2s0: associate with xx:xx:xx:xx:xx:xx (try 1/3)
[qua mar 23 10:05:44 2022] wlp2s0: RX AssocResp from xx:xx:xx:xx:xx:xx (capab=0xc11 status=0 aid=1)
[qua mar 23 10:05:44 2022] wlp2s0: associated
[qua mar 23 10:05:44 2022] ath: EEPROM regdomain: 0x804c
[qua mar 23 10:05:44 2022] ath: EEPROM indicates we should expect a country code
[qua mar 23 10:05:44 2022] ath: doing EEPROM country->regdmn map search
[qua mar 23 10:05:44 2022] ath: country maps to regdmn code: 0x3b
[qua mar 23 10:05:44 2022] ath: Country alpha2 being used: BR
[qua mar 23 10:05:44 2022] ath: Regpair used: 0x3b
[qua mar 23 10:05:44 2022] ath: regdomain 0x804c dynamically updated by country element
[qua mar 23 10:07:43 2022] i915 0000:00:02.0: [drm] HPD interrupt storm detected on connector DP-1: switching from hotplug detection to polling
[qua mar 23 10:12:20 2022] i915 0000:00:02.0: [drm] HPD interrupt storm detected on connector DP-1: switching from hotplug detection to polling
```

Comment 2 awfslot 2022-03-23 22:45:21 UTC
To reproduce: enable wireless and begin working.

Atheros wireless pauses and freezes after some bit of traffic, restarts.

 ...problem started in kernels after 5.16.14-200.fc35.x86_64 (which still works fine).

lspci-n: 07:00.0 0280: 168c:0032 (rev 01)

lspci: 07:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
	DeviceName: Maryann
	Subsystem: Hewlett-Packard Company Device 1785
	Flags: bus master, fast devsel, latency 0, IRQ 17
	Memory at f0300000 (64-bit, non-prefetchable) [size=512K]
	Expansion ROM at f0380000 [disabled] [size=64K]
	Capabilities: [40] Power Management version 2
	Capabilities: [50] MSI: Enable- Count=1/4 Maskable+ 64bit+
	Capabilities: [70] Express Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Virtual Channel
	Capabilities: [160] Device Serial Number 00-00-00-00-00-00-00-00
	Kernel driver in use: ath9k
	Kernel modules: ath9k

dmesg:
wlo1: authenticate with b0:95:75:13:32:3c
[  632.135381] wlo1: send auth to b0:95:75:13:32:3c (try 1/3)
[  632.244219] wlo1: send auth to b0:95:75:13:32:3c (try 2/3)
[  632.247997] wlo1: authenticated
[  632.249146] wlo1: associate with b0:95:75:13:32:3c (try 1/3)
[  632.256531] wlo1: RX AssocResp from b0:95:75:13:32:3c (capab=0x1031 status=0 
aid=2)
[  632.256714] wlo1: associated
[  638.176296] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_S   <<--- fail
W=0x02000020 DMADBG_7=0x00006100     

journalctl:
kernel: ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x020
00020 DMADBG_7=0x00006100

There is some kind of related work being done upstream, as noted on kernel mailing list.

Comment 3 William Bader 2022-03-24 10:11:12 UTC
I have a similar symptom with wifi pausing and ksoftirqd getting a lot of cpu with kernel 5.16.15-101.fc34.x86_64 but not with kernel 5.16.11-100.fc34.x86_64.
My laptop is Sony Vaio VPCCB4Q1E. dmesg has "ath9k 0000:02:00.0 wlp2s0: renamed from wlan0" and "usbcore: registered new interface driver ath3k"

Comment 4 Justin M. Forbes 2022-03-24 19:45:05 UTC
*** Bug 2068272 has been marked as a duplicate of this bug. ***

Comment 5 Joao Carvalho 2022-03-25 11:11:43 UTC
I had the same issue. Fedora 35 was working fine. On march 22nd wifi began to behave inconsistently immediately after upgrading the linux kernel from 5.16.15 to 5.16.16. I am using a Dell Inspiron 7520 and my wifi adapter is Qualcomm Atheros AR9485. Last night and this morning wifi seems to be working well, so I wonder if this has been fixed?

Comment 6 Joao Carvalho 2022-03-25 11:19:42 UTC
(In reply to Joao Carvalho from comment #5)
> Last night and this morning wifi seems to be
> working well, so I wonder if this has been fixed?

Wifi disconnected a couple of minutes after I posted this, so no, it hasn't been fixed. Problem remains.

Comment 7 Justin M. Forbes 2022-03-25 13:01:47 UTC
*** Bug 2068350 has been marked as a duplicate of this bug. ***

Comment 8 Ilya 2022-03-25 14:05:52 UTC
The same issue with kernels >5.16.14. Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01).

After about 1 minute the connection hangs. Pings do not go. The reconnection saves for yet another 1 minute. The excerpt of my dmesg:

[ 1818.528053] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x02000020 DMADBG_7=0x00006100
[ 1819.580136] wlp3s0: authenticate with xx:xx:xx:xx:xx:xx
[ 1819.602005] wlp3s0: send auth to xx:xx:xx:xx:xx:xx (try 1/3)
[ 1819.604705] wlp3s0: authenticated
[ 1819.606535] wlp3s0: associate with xx:xx:xx:xx:xx:xx (try 1/3)
[ 1819.617234] wlp3s0: RX AssocResp from xx:xx:xx:xx:xx:xx (capab=0x411 status=0 aid=1)
[ 1819.617424] wlp3s0: associated
[ 2247.546341] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x02000020 DMADBG_7=0x00006100
[ 2248.598664] wlp3s0: authenticate with xx:xx:xx:xx:xx:xx
[ 2248.620287] wlp3s0: send auth to xx:xx:xx:xx:xx:xx (try 1/3)
[ 2248.623891] wlp3s0: authenticated
[ 2248.625147] wlp3s0: associate with xx:xx:xx:xx:xx:xx (try 1/3)
[ 2248.636073] wlp3s0: RX AssocResp from xx:xx:xx:xx:xx:xx (capab=0x411 status=0 aid=1)
[ 2248.636294] wlp3s0: associated
[ 2435.570679] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x02000020 DMADBG_7=0x00006100
[ 2436.620959] wlp3s0: authenticate with xx:xx:xx:xx:xx:xx
[ 2436.641688] wlp3s0: send auth to xx:xx:xx:xx:xx:xx (try 1/3)
[ 2436.645636] wlp3s0: authenticated
[ 2436.647099] wlp3s0: associate with xx:xx:xx:xx:xx:xx (try 1/3)
[ 2436.657830] wlp3s0: RX AssocResp from xx:xx:xx:xx:xx:xx (capab=0x411 status=0 aid=1)
[ 2436.658060] wlp3s0: associated
[ 2780.941517] wlp3s0: deauthenticating from xx:xx:xx:xx:xx:xx by local choice (Reason: 3=DEAUTH_LEAVING)
[ 2782.508032] wlp3s0: authenticate with xx:xx:xx:xx:xx:xx
[ 2782.522917] wlp3s0: send auth to xx:xx:xx:xx:xx:xx (try 1/3)
[ 2782.524811] wlp3s0: authenticated
[ 2782.525098] wlp3s0: associate with xx:xx:xx:xx:xx:xx (try 1/3)
[ 2782.536162] wlp3s0: RX AssocResp from xx:xx:xx:xx:xx:xx (capab=0x411 status=0 aid=1)
[ 2782.536324] wlp3s0: associated
[ 2782.661372] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
[ 2943.697780] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x02000020 DMADBG_7=0x00006100
[ 2944.747908] wlp3s0: authenticate with xx:xx:xx:xx:xx:xx
[ 2944.769749] wlp3s0: send auth to xx:xx:xx:xx:xx:xx (try 1/3)
[ 2944.777727] wlp3s0: authenticated
[ 2944.778259] wlp3s0: associate with xx:xx:xx:xx:xx:xx (try 1/3)
[ 2944.790043] wlp3s0: RX AssocResp from xx:xx:xx:xx:xx:xx (capab=0x411 status=0 aid=1)
[ 2944.790321] wlp3s0: associated
[ 3003.746021] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x02000020 DMADBG_7=0x00006100
[ 3004.796532] wlp3s0: authenticate with xx:xx:xx:xx:xx:xx
[ 3004.817204] wlp3s0: send auth to xx:xx:xx:xx:xx:xx (try 1/3)
[ 3004.824695] wlp3s0: authenticated
[ 3004.825411] wlp3s0: associate with xx:xx:xx:xx:xx:xx (try 1/3)
[ 3004.839099] wlp3s0: RX AssocResp from xx:xx:xx:xx:xx:xx (capab=0x411 status=0 aid=1)
[ 3004.839289] wlp3s0: associated
[ 3014.840096] wlp3s0: deauthenticating from xx:xx:xx:xx:xx:xx by local choice (Reason: 3=DEAUTH_LEAVING)
[ 3014.868889] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x02000020 DMADBG_7=0x00006100
[ 3015.924090] wlp3s0: authenticate with xx:xx:xx:xx:xx:xx
[ 3015.945144] wlp3s0: send auth to xx:xx:xx:xx:xx:xx (try 1/3)
[ 3015.947781] wlp3s0: authenticated
[ 3015.948183] wlp3s0: associate with xx:xx:xx:xx:xx:xx (try 1/3)
[ 3015.959638] wlp3s0: RX AssocResp from xx:xx:xx:xx:xx:xx (capab=0x411 status=0 aid=1)
[ 3015.959816] wlp3s0: associated
[ 3018.729934] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x02000020 DMADBG_7=0x00006100
[ 3019.778887] wlp3s0: authenticate with xx:xx:xx:xx:xx:xx
[ 3019.800849] wlp3s0: send auth to xx:xx:xx:xx:xx:xx (try 1/3)
[ 3019.805622] wlp3s0: authenticated
[ 3019.806178] wlp3s0: associate with xx:xx:xx:xx:xx:xx (try 1/3)
[ 3019.818719] wlp3s0: RX AssocResp from xx:xx:xx:xx:xx:xx (capab=0x411 status=0 aid=1)
[ 3019.818909] wlp3s0: associated

Thanks in advance.

Comment 9 Justin M. Forbes 2022-03-25 15:13:24 UTC
If anyone wants to give https://koji.fedoraproject.org/koji/taskinfo?taskID=84697781 a try, and let me know if it works for you. It is not secure boot signed because it is a scratch build, but it contains a patch that upstream is tossing around. There is a still a considerable amount of discussion on it.

Comment 10 Ibrahim Ansari 2022-03-25 15:18:33 UTC
Would like to add that I'm running Fedora 36 Workstation Pre-release, and this issue is happening with me after the update from Linux 5.17-rc7 to 5.17 as well, this issue is not just limited to 5.16.x series.

lspci:
09:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)

dmesg:
[12193.613742] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x02000020 DMADBG_7=0x00006100
[12194.669386] wlp9s0: authenticate with xx:xx:xx:xx:xx:xx
[12194.669427] wlp9s0: bad VHT capabilities, disabling VHT
[12194.669432] wlp9s0: 80 MHz not supported, disabling VHT
[12194.687759] wlp9s0: send auth to xx:xx:xx:xx:xx:xx (try 1/3)
[12194.701654] wlp9s0: authenticated
[12194.701806] wlp9s0: associating with AP with corrupt probe response
[12194.702140] wlp9s0: associate with xx:xx:xx:xx:xx:xx (try 1/3)
[12194.708789] wlp9s0: RX AssocResp from xx:xx:xx:xx:xx:xx (capab=0x411 status=0 aid=1)
[12194.708917] wlp9s0: associated
[12194.709086] ath: EEPROM regdomain: 0x8164
[12194.709090] ath: EEPROM indicates we should expect a country code
[12194.709091] ath: doing EEPROM country->regdmn map search
[12194.709093] ath: country maps to regdmn code: 0x5b
[12194.709094] ath: Country alpha2 being used: IN
[12194.709096] ath: Regpair used: 0x5b
[12194.709098] ath: regdomain 0x8164 dynamically updated by country element

Essentially identical to the above reports.

Comment 11 Justin M. Forbes 2022-03-25 16:39:25 UTC
Yes, that would make since given that upstream has not accepted a fix yet.

Comment 12 Ilya 2022-03-26 11:32:28 UTC
(In reply to Justin M. Forbes from comment #9)
> If anyone wants to give
> https://koji.fedoraproject.org/koji/taskinfo?taskID=84697781 a try, and let
> me know if it works for you. It is not secure boot signed because it is a
> scratch build, but it contains a patch that upstream is tossing around.
> There is a still a considerable amount of discussion on it.

Had to recompile it for Fedora 34 using 

$ rpmbuild -ba  -without=debug -without=debuginfo kernel.spec

Now the connection stays stable, pings go, but the string "ath: phy0: DMA failed to stop" is still here.

[  319.773168] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[  319.773174] Bluetooth: BNEP filters: protocol multicast
[  319.773179] Bluetooth: BNEP socket layer initialized
[  331.965969] usb 1-1.5: Failed to query (GET_DEF) UVC control 13 on unit 1: -32 (exp. 8).
[  367.816339] wlp3s0: authenticate with xx:xx:xx:xx:xx:xx
[  367.837359] wlp3s0: send auth to xx:xx:xx:xx:xx:xx (try 1/3)
[  367.840020] wlp3s0: authenticated
[  367.840645] wlp3s0: associate with xx:xx:xx:xx:xx:xx (try 1/3)
[  367.851709] wlp3s0: RX AssocResp from xx:xx:xx:xx:xx:xx (capab=0x411 status=0 aid=1)
[  367.851909] wlp3s0: associated
[  367.986877] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
[  791.983102] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x02000020 DMADBG_7=0x0000a400
[  818.670005] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000028 AR_DIAG_SW=0x02000020 DMADBG_7=0x0000a400
[  936.491263] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000028 AR_DIAG_SW=0x02000020 DMADBG_7=0x0000a400

Comment 13 Andrew Chambers 2022-03-27 03:52:54 UTC
(In reply to Justin M. Forbes from comment #9)

This fixes my, Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter - many thanks.

Before this patch, when streaming videos, my Acer Aspire E1-570 laptop's log repeatedly contained the message

  wpa_supplicant[959]: wlp3s0: CTRL-EVENT-BEACON-LOSS

when using any of the 3 following kernel versions

   5.16.15-201.fc35.x86_64
   5.16.16-200.fc35.x86_64
   5.16.17-200.fc35.x86_64

The patch in the 5.16.17-201.fc35.x86_64 kernel, fixes the above ath9k driver issue for my laptop.
Now I don't have to revert back to kernel version 5.16.14-200.fc35.x86_64, to get perfect Wi-Fi access.

Comment 14 Fedora Update System 2022-03-28 18:08:45 UTC
FEDORA-2022-eb323bcd80 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-eb323bcd80

Comment 15 Fedora Update System 2022-03-28 18:08:54 UTC
FEDORA-2022-8e3ac65667 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2022-8e3ac65667

Comment 16 Fedora Update System 2022-03-29 01:32:08 UTC
FEDORA-2022-eb323bcd80 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-eb323bcd80`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-eb323bcd80

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Fedora Update System 2022-03-29 01:39:38 UTC
FEDORA-2022-8e3ac65667 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-8e3ac65667`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-8e3ac65667

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 18 Ibrahim Ansari 2022-03-29 13:49:30 UTC
This bug seems to be fixed for me since updating to Linux 5.17.1 kernel as well.

Comment 19 Ilya 2022-03-29 14:03:59 UTC
$ uname -a
Linux fedora 5.16.18-100.fc34.x86_64 #1 SMP PREEMPT Mon Mar 28 14:46:06 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

The string "ath: phy0: DMA failed to stop" is no more. 

$ dmesg | grep ath

[   10.436355] systemd[1]: Listening on multipathd control socket.
[   19.277669] ath: phy0: ASPM enabled: 0x43
[   19.277678] ath: EEPROM regdomain: 0x60
[   19.277679] ath: EEPROM indicates we should expect a direct regpair map
[   19.277682] ath: Country alpha2 being used: 00
[   19.277683] ath: Regpair used: 0x60
[   19.533424] ath9k 0000:03:00.0 wlp3s0: renamed from wlan0
[   21.764876] usbcore: registered new interface driver ath3k

Thanks again.

Comment 20 Andrew Chambers 2022-03-29 18:08:29 UTC
(In reply to Fedora Update System from comment #14)

Thanks for back porting the fix into Fedora from mainline.

Comment 21 Fedora Update System 2022-03-30 01:11:26 UTC
FEDORA-2022-8e3ac65667 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 22 Fedora Update System 2022-03-30 01:28:50 UTC
FEDORA-2022-eb323bcd80 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.