Bug 206713 - graphviz requires X-libraries
Summary: graphviz requires X-libraries
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: graphviz   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jima
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FE7Target
TreeView+ depends on / blocked
 
Reported: 2006-09-15 20:38 UTC by Roy-Magne Mo
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-14 13:40:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Roy-Magne Mo 2006-09-15 20:38:43 UTC
Description of problem:
As of graphviz-2.8-4.fc5, graphviz started depending on X-libraries. I can see
nothing in the changelog indicating any change. If there is dependencies on X,
can this be split into its own subpackage?

Version-Release number of selected component (if applicable):
graphviz-2.8-4.fc5

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Alex Lancaster 2006-09-16 08:48:06 UTC
graphviz-2.8-3.fc5 (previous version) didn't depend on the X libraries because
the previous version's package was broken.  It was erroneously missing the
/usr/bin/lefty binary, which is built against X:

$ ldd /usr/bin/lefty
        linux-gate.so.1 =>  (0xffffe000)
        libXaw.so.7 => /usr/lib/libXaw.so.7 (0x0016a000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0x00b41000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0x00a94000)
        libXpm.so.4 => /usr/lib/libXpm.so.4 (0x00b27000)
        libXt.so.6 => /usr/lib/libXt.so.6 (0x0041b000)
        libXmu.so.6 => /usr/lib/libXmu.so.6 (0x00ab0000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0x00d14000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0x00971000)
        libm.so.6 => /lib/libm.so.6 (0xb7f59000)
        libc.so.6 => /lib/libc.so.6 (0xb7e26000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0x00d0f000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00d07000)
        libdl.so.2 => /lib/libdl.so.2 (0xb7e21000)
        /lib/ld-linux.so.2 (0xb7fa5000)

Without this binary, however, many of the programs in graphviz (dotty, lneato)
etc. are non-functional.

The non-graphical versions of these programs (dot, neato) which were included in
the broken package don't rely on X and so it didn't pull in X as a requirement.  

I suppose the graphical programs such as dotty, lneato and lefty could be split
out into a subpackage, but upstream doesn't do it that way and graphviz is
inherently a package for generating graphs that are supposed to viewed.

Comment 2 Roy-Magne Mo 2006-09-16 14:19:26 UTC
I just reported it partly as a question, since it was a dependency for an
another package - I'm not using it myself. But generally, if there is parts of
the graphviz package that has a use without the X-libraries, the X-dependant
files should be packaged for itself - for use on servers and such.

Comment 3 Jima 2006-10-03 16:37:59 UTC
Taking ownership of this bug, as it's my package now.

I'm somewhat stalling, waiting for Graphviz 2.10; if it doesn't show up soon I
guess I'll be giving the package an overhaul, to see if there are
non-X-dependent components to leave in the main package while splitting off the
X-dependent bits to a subpackage (along with the dependencies).

Comment 4 Jima 2006-10-04 21:30:35 UTC
Alex, Roy-Magne: After some looking, it appears that the only thing in the
package that pulls in the X dependencies is (as Alex hinted) lefty.  The
remaining significant dependencies are:

expat
fontconfig
freetype
libjpeg
libpng
libtool-ltdl
zlib

My question (as a graphviz non-user) is, how useful is the package without
lefty?  Is it worth splitting lefty off to its own subpackage?  If so, any
suggestions on what to call it?  graphviz-gui?

I was just looking at the package again today because I need to rebuild it (for
other reasons).  I think I'll push this build as-is, and make the changes
if/when I get a good answer to this.

Thanks.

Comment 5 Jima 2007-02-14 13:40:44 UTC
The lack of response makes me suspect this isn't particularly critical.  Closing
as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.