Bug 206734 - wrong URL's in /etc/sysconfig/rhn/up2date can cause yum to hang
wrong URL's in /etc/sysconfig/rhn/up2date can cause yum to hang
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
Beth Nackashi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-15 18:26 EDT by Michael DeHaan
Modified: 2013-01-10 03:55 EST (History)
1 user (show)

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 19:17:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael DeHaan 2006-09-15 18:26:37 EDT
Description of problem:

Certain forms of bogus URL's in /etc/sysconfig/rhn/up2date can cause yum to hang
indefinitely.  As far as I can tell, there's no good way to figure out the
source of the error.

Wrong URL's originally used that hang yum:

noSSLServerURL=http://rhn.webqa.redhat.com/xmlrpc
SSLServerURL=http://rhn.webqa.redhat.com/xmlrpc

Correct (no-hang) URL's:

noSSLServerURL=http://xmlrpc.rhn.webqa.redhat.com/XMLRPC
SSLServerURL=http://xmlrpc.rhn.webqa.redhat.com/XMLRPC

How I stumbled upon this:  In this particular example, I keyed in the wrong
URL's to rhn_reg_ks and then found this out when I tried to use yum for the
first time.  You can still get the same symptom by changing an existing
installation to the "wrong" URL's above.

Version-Release number of selected component (if applicable):

RHEL 5 Beta 1

How reproducible:

Consistant

Steps to Reproduce:
1.   Install RHEL 5.
2.   edit /etc/sysconfig/rhn/up2date to use the following server URL's
3.   yum update
  
Actual results:

yum hangs and must be killed or suspended (Ctrl+C doesn't work).

Expected results:

An eventual error message about the connection problem should be shown and yum
should exit.

Additional info:

certain "wrong" URL's (such as just changing the string "webqa" to "bogus", i.e.
http://xmlrpc.rhn.bogus.redhat.com/XMLRPC *don't* cause an infinite hang, they
eventually cause a connection failed traceback, I didn't explore much further to
find out exactly what part of the URL being wrong caused problems, though the
first "wrong" URL's mentioned in this report do cause the lockup.
Comment 1 James Bowes 2006-09-19 16:47:19 EDT
This is the same bug as #177062. But we'll leave this one open, I guess, since
it's for RHEL 5.
Comment 2 James Bowes 2006-09-25 12:06:15 EDT
And just like #177062, it should be fixed.
Comment 3 Fanny Augustin 2006-12-04 13:47:00 EST
It only happens if someone misconfig it.  Not a blocker.
Comment 4 RHEL Product and Program Management 2006-12-22 19:17:31 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.