Bug 206735 - Cannot do nfs install
Cannot do nfs install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-09-15 18:40 EDT by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 09:50:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda log (41.66 KB, text/plain)
2006-09-15 18:40 EDT, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2006-09-15 18:40:49 EDT
PXE kickstart install. The following repositories are defined:

nfs --server=saga --dir=/export/data1/fedora/core/6/i386/os
repo --name=updates --baseurl=http://www.cora.nwra.com/fedora/updates/6/i386/
repo --name=extras --baseurl=http://www.cora.nwra.com/fedora/extras/6/i386/
repo --name=CoRA --baseurl=http://www.cora.nwra.com/fedora/CoRPMS/6/i386/
repo --name=livna --baseurl=http://www.cora.nwra.com/fedora/livna/6/i386/

(note that it complains about non-existant updates and livna)

but the install fails when starting to install packages and cannot find
cups-1.2.3-3.i386.rpm (which is the first to be installed.  anaconda.log shows:

16:16:09 WARNING : Try 10/10 for
file:///mnt/source/./Fedora/RPMS/cups-1.2.3-3.i386.rpm failed

but in the shell I can see /mnt/source/./Fedora/RPMS/cups-1.2.3-3.i386.rpm just
fine.  File seem okay too.

BTW - it would be nice to specify other repositories with nfs: urls.
Comment 1 Orion Poplawski 2006-09-15 18:40:49 EDT
Created attachment 136406 [details]
anaconda log
Comment 2 Orion Poplawski 2006-09-18 16:10:02 EDT
Also fails with:

url --url http://www.cora.nwra.com/fedora/core/6/i386/os
repo --name=updates --baseurl=http://www.cora.nwra.com/fedora/updates/6/i386/
repo --name=extras --baseurl=http://www.cora.nwra.com/fedora/extras/6/i386/
repo --name=CoRA --baseurl=http://www.cora.nwra.com/fedora/CoRPMS/6/i386/
repo --name=livna --baseurl=http://www.cora.nwra.com/fedora/livna/6/i386/

and:

nfs --server=saga --dir=/export/data1/fedora/core/6/i386/os

Verified the md5sum of cups-1.2.3-3.i386.rpm against the Fedora download server.
Comment 3 Chris Lumens 2006-09-19 14:30:04 EDT
Is there a /mnt/sysimage/root/install.log?  cups should not be the first package
to get installed, so I'm wondering if perhaps something else snuck in before it.
 If cups is actually the first package to be installed, this looks like some
sort of package ordering problem.

Does the install work if you don't use any other repositories?
Comment 4 Orion Poplawski 2006-09-19 18:13:09 EDT
install.log is empty.  Same result without the "repo" lines.

Install of today's (20060919) rawhide went fine.  Maybe my test3 copy is bad,
though I'm not quite sure how.
Comment 5 Chris Lumens 2006-09-20 09:50:41 EDT
Odd.  Well, it's possible we fixed something in anaconda (a quick scan of the
spec file doesn't have anything jumping out as obvious, though there are a ton
of changes).  And of course it's possible there was something funny in the
kernel NFS code or utilities that has been sorted out in the meantime.  I'm
going to close this as RAWHIDE, but feel free to reopen it if the problem comes
back.

Note You need to log in before you can comment on or make changes to this bug.