Bug 206738 - rescue mode broken in rawhide
rescue mode broken in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-15 19:13 EDT by Aron Griffis
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 12:07:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aron Griffis 2006-09-15 19:13:52 EDT
Description of problem:
Trying to using xenguest-install with "rescue" generates a traceback from anaconda.



Version-Release number of selected component (if applicable):
anaconda-11.1.0.97-1

How reproducible:
100%

Steps to Reproduce:
1. xenguest-install -n domu -r 512 -f /root/domu.img -s 4 --nographics -p -l
http://hummer.zko.hp.com/fedora/linux/core/development/ia64/os/ -x 'ide0=noprobe
ide1=noprobe ide2=noprobe ide3=noprobe rescue nomount'

You could probably reproduce it simply booting a Rawhide CD with "rescue" since
the bug seems to be pretty apparent in the anaconda code.
  
Actual results:
    Running anaconda, the Fedora Core rescue mode - please wait...
    Traceback (most recent call last):
      File "/usr/bin/anaconda", line 703, in ?
        rescue.runRescue(anaconda)
      File "/usr/lib/anaconda/rescue.py", line 260, in runRescue
        runShell(screen)
    UnboundLocalError: local variable 'screen' referenced before assignment
    install exited abnormally [1/1]

Expected results:
Rescue shell
Comment 1 Chris Lumens 2006-09-18 12:07:09 EDT
Jeremy fixed this on Friday and it'll be in the next build.

Note You need to log in before you can comment on or make changes to this bug.