Bug 20675 - i810 hard disk controller
i810 hard disk controller
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brock Organ
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-11 04:59 EST by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 14:50:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Result of dmesg (4.46 KB, text/plain)
2000-11-14 15:37 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2000-11-11 04:59:03 EST
I have upgraded my RedHat Linux 6.2fr to 7.0.

When I boot my PC with Linux, the controller is badly recognized, but it 
works. But, when rebooting and going back to Windows, the hard disks go 
very slowly. I must turn off the computer and switch it on again to 
restore a proper function.

It sometimes happens with a direct boot to Windows, so it seems to be in 
Lilo, but it is maybe 1% of the direct boot. As a second boot, the problem 
is nearly always.

It had never happened before the installation of RedHat 6.2 + Lilo.

My computer is a Packard Bell "Club 2500c".

****** I do not know the component name *****
Comment 1 Michael Fulbright 2000-11-13 14:28:12 EST
Passed to QA to reproduce.
Comment 2 Brock Organ 2000-11-14 14:38:05 EST
hmmm ... can you attach the output from dmesg ... it should list your hard
drives ...
Comment 3 Need Real Name 2000-11-14 15:37:19 EST
Created attachment 5340 [details]
Result of dmesg
Comment 4 Need Real Name 2000-12-03 08:36:52 EST
I do not understand why the status is still NEEDINFO. I have created an 
attachement with the information required...
Comment 5 Brock Organ 2000-12-18 13:33:19 EST
hi Jean!

Thanks for your dmesg output ... your hard drives list is fairly sane, but we
have not heard other reports of folks with these drives having this problem nor
are we able to reproduce the behavior in our test lab ... 

one thing to try, since you think that lilo may have something to do with the
situation.  Can you make a floppy bootdisk, and then uninstall lilo from the
hard drive ...?  If so, do these problems persist when you boot linux from the
floppy (and have the mbr restored to what it was before lilo) ...?

additionally, as the bug reporter, you are free to change the state of the bug
as needed, and so the reporter usually changes the bug state from needinfo when
replying with the necessary information ... sorry if that wasn't clear ... :)
Comment 6 Need Real Name 2000-12-29 11:41:14 EST
I cannot restore the standard Windows 98 boot sector, because I had a crash on 
my first install and the second destroyed the save file.

Maybe you could send me a procedure or a Windows program, to dump the memory 
and the disk controller registers, in order to send you an image of the system. 
The problem is now at every reboot.
Comment 7 Michael Fulbright 2001-01-19 19:04:35 EST
I believe you can use a windows boot floppy with the DOS FDISK program on it,
boot this and run 'fdisk /mbr'.

This should let you reboot into windows.
Comment 8 Need Real Name 2001-01-28 13:05:43 EST
It's OK. I have made a Linux floppy disk with mkbootdisk, uninstall Lilo with 
lilo -u, and restored my Windows boot record with fdisk /mbr (I did not know 
this option).
Great thanks.
You can close this bug for me. But it remain that something seems not to 
initialise correctly the controler. I have forwarded the problem to Packard 
Bell, for a BIOS enhancement, but I have no answer...
Comment 9 Michael Fulbright 2001-02-01 14:50:44 EST
Ok glad everything is back to normal.
Comment 10 Need Real Name 2001-03-03 09:23:31 EST
Some more information about my disk controller: Even having restored the normal 
Windows boot, I still have the problem (I thought it was stopped, but it still 
happens). I think that the problem does not come from the Lilo boot, but either 
from the i810 controller or from my BIOS. I suppose it is because my EIDE bus 
is full (2 hard disks, 1 DVD and 1 CD-Writer) and, so, maybe it is not 
correctly supported. You told me, in a previous message, that you could not 
reproduce the problem, but maybe with this clue you can... if it has any 
interest for you.

Note You need to log in before you can comment on or make changes to this bug.