Bug 206750 - Cups does not start
Cups does not start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
rawhide
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-09-16 00:15 EDT by louisgtwo
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 18:20:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cups dosen't start (2.34 KB, text/plain)
2006-09-16 15:02 EDT, louisgtwo
no flags Details

  None (edit)
Description louisgtwo 2006-09-16 00:15:37 EDT
Trying to get cups running on test3 and it dies. This is the error log
of cups. I'm on a local ipv4 network by the way.

I [15/Sep/2006:22:13:43 -0400] Listening to ::1:631 (IPv6)
I [15/Sep/2006:22:13:43 -0400] Listening to /var/run/cups/cups.sock
(Domain)
I [15/Sep/2006:22:13:43 -0400] Loaded configuration file
"/etc/cups/cupsd.conf"
W [15/Sep/2006:22:13:43 -0400] Repairing access permissions of
"/etc/cups/classes.conf"
I [15/Sep/2006:22:13:43 -0400] Using default TempDir
of /var/spool/cups/tmp...
I [15/Sep/2006:22:13:43 -0400] Cleaning out old temporary files in
"/var/spool/cups/tmp"...
I [15/Sep/2006:22:13:43 -0400] Configured for up to 100 clients.
I [15/Sep/2006:22:13:43 -0400] Allowing up to 100 client connections per
host.
I [15/Sep/2006:22:13:43 -0400] Using policy "default" as the default!
I [15/Sep/2006:22:13:43 -0400] Full reload is required.
I [15/Sep/2006:22:13:43 -0400] Loaded MIME database from '/etc/cups': 34
types, 36 filters...
I [15/Sep/2006:22:13:43 -0400] Loading NextJobId from job cache file
"/var/cache/cups/job.cache"...
I [15/Sep/2006:22:13:43 -0400] Full reload complete.
E [15/Sep/2006:22:13:43 -0400] Unable to bind socket for address ::1:631
- Address already in use.
I [15/Sep/2006:22:13:43 -0400] Listening to /var/run/cups/cups.sock on
fd 3...
E [15/Sep/2006:22:13:43 -0400] cupsdStartBrowsing: Unable to bind
broadcast socket - Address already in use.
Comment 1 Tim Waugh 2006-09-16 06:28:06 EDT
I don't see this here on a fresh install.  Please attach your
/etc/cups/cupsd.conf file.  Thanks.
Comment 2 louisgtwo 2006-09-16 15:02:27 EDT
Created attachment 136441 [details]
cups dosen't start
Comment 3 louisgtwo 2006-09-16 22:04:51 EDT
Maybe an selinux issue. With selinux in permissive mode cups workes fine. With
selinux in enforcing mode cupsd dies.
Comment 4 louisgtwo 2006-09-16 23:12:25 EDT
I reinstalled test3 and updated to rawhide as of sep 15. Cups was running after
the initial install but when I updated and rebooted cups was dead. I am using a
ppd file for a printer I just got. This worked with test2 on but not now. As I
said before this works with selinux=0. I get no avc messages though. Seems it's
not able to bind to a socket.

I [16/Sep/2006:23:05:05 -0400] Listening to 127.0.0.1:631 (IPv4)
I [16/Sep/2006:23:05:05 -0400] Listening to ::1:631 (IPv6)
I [16/Sep/2006:23:05:05 -0400] Listening to /var/run/cups/cups.sock (Domain)
I [16/Sep/2006:23:05:05 -0400] Loaded configuration file "/etc/cups/cupsd.conf"
I [16/Sep/2006:23:05:05 -0400] Using default TempDir of /var/spool/cups/tmp...
I [16/Sep/2006:23:05:05 -0400] Cleaning out old temporary files in
"/var/spool/cups/tmp"...
I [16/Sep/2006:23:05:05 -0400] Configured for up to 100 clients.
I [16/Sep/2006:23:05:05 -0400] Allowing up to 100 client connections per host.
I [16/Sep/2006:23:05:05 -0400] Using policy "default" as the default!
I [16/Sep/2006:23:05:05 -0400] Full reload is required.
I [16/Sep/2006:23:05:05 -0400] Loaded MIME database from '/etc/cups': 34 types,
38 filters...
I [16/Sep/2006:23:05:05 -0400] Loading job cache file "/var/cache/cups/job.cache"...
I [16/Sep/2006:23:05:05 -0400] Full reload complete.
E [16/Sep/2006:23:05:05 -0400] Unable to bind socket for address 127.0.0.1:631 -
Address already in use.
E [16/Sep/2006:23:05:05 -0400] Unable to bind socket for address ::1:631 -
Address already in use.
I [16/Sep/2006:23:05:05 -0400] Listening to /var/run/cups/cups.sock on fd 3...
E [16/Sep/2006:23:05:05 -0400] cupsdStartBrowsing: Unable to bind broadcast
socket - Address already in use.
Comment 5 Tim Waugh 2006-09-17 07:03:06 EDT
This problem is mentioned in an upstream bug report:
  http://cups.org/str.php?L1976
Comment 6 louisgtwo 2006-09-20 18:20:49 EDT
Seems to be fixed with 09/20/2006 rawhide update. selinux-policy-2.3.14-6

Note You need to log in before you can comment on or make changes to this bug.