Bug 206775 - gkrellm still does not show up in gnome desktop menu
gkrellm still does not show up in gnome desktop menu
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gkrellm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-16 10:55 EDT by David Timms
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-22 16:23:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to make gkrellm icon actually appear (945 bytes, text/x-patch)
2006-09-16 10:59 EDT, David Timms
no flags Details

  None (edit)
Description David Timms 2006-09-16 10:55:06 EDT
Description of problem:
When gkrellm is installed, a menu icon is not displayed

Version-Release number of selected component (if applicable):
gkrellm-2.2.9-8 from fc6t3.
also present since fc5.

How reproducible:
yes.

Steps to Reproduce:
1. yum install gkrellm
2. look in applications and system menus for the gkrellm icon
  
Actual results:
absent

Expected results:
should be present under either application|system tools or system|administration

Additional info:
The package properly installs the png icon, and the gnome-gkrellm.desktop file
to the correct directory, however, it does not appear in the menus.

In trying to solve this I noticed the info:
http://fedora.redhat.com/docs/developers-guide/ch-menus.html , which says not to
make multiple applications appear in the menu at the same level when the
applications purpose are the same.

It seems that the fact that there is two apps with the same function:
Application;System;Monitor, then only the one is shown. For example changing the
Categories in the .desktop file to be Applications;Office {for eg like dia},
succesfully makes the icon appear in the Office menu.

If X-Red-Hat-Base is added, then the icon is shown in the system|administration
menu. The attached patch does this.
Comment 1 David Timms 2006-09-16 10:59:42 EDT
Created attachment 136428 [details]
patch to make gkrellm icon actually appear

Since I'm not fully clear on fedora's current guidelines, this may not be the
proper approach; it does however make the menu item appear.
Comment 2 Hans de Goede 2006-09-22 08:43:48 EDT
Hmm,

Yes that might work another option/hack would be to remove the "Monitor" part
from the "Application;System;Monitor" list, then gkrellm would show up under
applications->system tools, which IMHO is a better place (and is where gtop
should be too, but thats a different story).

What do you think about this?
Comment 3 David Timms 2006-09-22 10:49:18 EDT
Applications|System Tools would make most sense to me, and it is where it used
to live. Also it seems that:
http://standards.freedesktop.org/menu-spec/latest/apa.html - 
Additional Category|	Description	                      |Related Categories
Monitor|Monitor application/applet that monitors some resource or activity|System
, suggests gkrellm should be in the system and monitor category.

gnome-system-monitor on the other hand lives under System|Administration

But I guess there is still a further mapping regarding the X-Red-Hat-Base stuff.
Comment 4 Hans de Goede 2006-09-22 16:23:06 EDT
2.2.9-9 should show up on a mirror near you soon, with this version gkrellm will
show under the Applications|System menu.
Comment 5 David Timms 2006-09-25 09:41:01 EDT
Nice work Hans, with the new package as received from extras-devel, the icon
does show up as described in comment 4 :)

Note You need to log in before you can comment on or make changes to this bug.