Bug 206778 - minimal install: requests 5 CDs, but just for 1 or 2 files on disc 3,4,5
minimal install: requests 5 CDs, but just for 1 or 2 files on disc 3,4,5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-09-16 11:36 EDT by David Timms
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 17:27:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Timms 2006-09-16 11:36:31 EDT
Description of problem:
In anaconda, although unselecting all items in the basic package screen,
installer decides all 5 CDs will be needed.  

Version-Release number of selected component (if applicable):
anaconda fc6t3

Steps to Reproduce:
1. install from CD
2. unselect all options on the basic package selection screen
unchecking the 3 checkboxes:
office
web server
{forgotten}
and enabling/disable extras repo 
3. next
  
Actual results:
~you'll need cd 1 2 3 4 5.

Expected results:
should require no more than 2 cd's (preferably one).

Additional info:
All 5 CD's are actually requested during package installation.
with everything unselected, need disc1-5
message from VT ~3/4
switching from cd[1] to 1 for vim-enhanced
after disc1: 10 minute left:
switching from cd[1] to 2 for evince
after disc2: 2 minutes left
switching from cd[2] to 3 for wvdial
after disc3: 2 minutes left
switching from cd[3] to 4 for isdn4k-utils {10M}

Disk 3 4 and 5 are only needed for about 20 seconds each.
Comment 1 David Timms 2006-09-16 11:46:37 EDT
I think this is different from bug 195941.
Comment 2 David Timms 2006-09-17 11:48:01 EDT
I compared the list of installed packages and found the following culprits:
libwvstreams-4.2.2-2.1    d3 {needed by wvdial}
wvdial-1.54.0-5.2.2.1     d3 (needed by nothing} 
isdn4k-utils-3.2-50       d4 (needed by nothing}
libsepol-devel-1.12.25-3  d4 {needed by libselinux-python which needs
policycoreutils and -> 101 packages: xorg-foo, beagle-foo, evolution,gimp,gtk, etc}
lrzsz-0.12.20-22.1        d4 (needed by nothing}
minicom-2.1-3             d5 (needed by nothing}
--size  disc          package
 673474 3/Fedora/RPMS/libwvstreams-4.2.2-2.1.i386.rpm
 133663 3/Fedora/RPMS/wvdial-1.54.0-5.2.2.1.i386.rpm
4048910 4/Fedora/RPMS/isdn4k-utils-3.2-50.i386.rpm
 174962 4/Fedora/RPMS/libsepol-devel-1.12.25-3.i386.rpm
  83368 4/Fedora/RPMS/lrzsz-0.12.20-22.1.i386.rpm
 260802 5/Fedora/RPMS/minicom-2.1-3.i386.rpm
--
disc sizes:
cd1 719669248 
cd2 716306432
-   = 3362816
above rpms (- isdn4k-utils) sum=1326269, even with overhead, should fit on CD2
OK. {and is isdn4k needed by average joe?).

Or all the above packages could be moved to disc3, since there would be enough
space on it.

Downloading and burning 3 extra CD's to get 7.14 MB of rpms is a bit sad ;(
Comment 3 Wensheng Wang 2006-09-18 04:28:49 EDT
I confirm this bug.
I use text install, after uncheck everything it still show 5 cd's are needed.

I remember fc4 require 1 cd for minimal install.
fc5 require 2 cd's for minimal install.

I like it to be just one cd. The fact is using as a server we can yum install
everything from the network.  We really just need a minimal system to start with.

Thanks
Comment 4 Jeremy Katz 2006-10-02 17:27:57 EDT
Should be fixed now
Comment 5 David Timms 2006-10-06 08:00:57 EDT
Finally got 6pre torrent cd's 1 and 2 downloaded. It appears that this fix
didn't make it into these images, since it still asks for disk 1-5 when you
deselect the office item and extras. This would seem likely given the cd has
files from 2006-09-29 but Jeremy posted 'fixed' a few days later. I guess it
would be a good idea to test this internally before release :)
Comment 6 Jeremy Katz 2006-10-06 11:05:48 EDT
Yep, Jesse verified it after my commit.  And it's on the testing punch list for
the final tree

Note You need to log in before you can comment on or make changes to this bug.