Bug 206779 - VFS: cannot open device "sda2" on unknown block(0,0)
VFS: cannot open device "sda2" on unknown block(0,0)
Status: CLOSED DUPLICATE of bug 206453
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2006-09-16 12:04 EDT by Jack
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-09-18 13:54:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jack 2006-09-16 12:04:17 EDT
Description of problem:
The boot drive is sda, the boot partition is on sda1, and / is on sda2.  But 
the error indicates that the sda2 partion cannot be opened.  The rest of the 
message states, "Please append a correct "root=" boot option.  Then the system 
halts at a kernel panic.

Version-Release number of selected component (if applicable):
Standard FC6.test3

How reproducible:
Every time

Steps to Reproduce:
1.  Load OS
2.  Reboot
Actual results:
Kernel Panic

Expected results:
No Kernel Panic

Additional info:
This is using a HP a1450n with a SATA drive.  refer to the link below for 
hardware details.  http://www.shopping.hp.com/webapp/shopping/store_access.do?
I haven't checked, but my suspicion is the SATA (Nvidia) driver is set to load 
as a module by default.  The grub.conf looks alright.
Comment 1 Dave Jones 2006-09-17 00:28:22 EDT
Something is horribly wrong with anaconda in test3. On all the systems I've
tried installing so far, it fails to install an initrd.

If you boot to rescue mode (boot the CD with 'linux rescue'), /mnt/sysimage/boot
has no initrd present.
Comment 2 Jeremy Katz 2006-09-18 13:54:16 EDT

*** This bug has been marked as a duplicate of 206453 ***

Note You need to log in before you can comment on or make changes to this bug.