Bug 206782 - perl-IO-Socket-SSL: update request to latest version (0.998-1.01)
perl-IO-Socket-SSL: update request to latest version (0.998-1.01)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-IO-Socket-SSL (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
:
Depends On:
Blocks: 171491
  Show dependency treegraph
 
Reported: 2006-09-16 13:17 EDT by Jose Pedro Oliveira
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 13:32:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose Pedro Oliveira 2006-09-16 13:17:09 EDT
Version-Release number of selected component (if applicable):
rawhide: IO-Socket-SSL 0.998
cpan: IO-Socket-SSL 1.01

Additional info:
CPAN homepage:
http://search.cpan.org/dist/IO-Socket-SSL/

Diff from rawhide version:
http://search.cpan.org/diff?from=IO-Socket-SSL-0.998&to=IO-Socket-SSL-1.01

Changelog
+v1.01
+       - work around Bug in Net::HTTPS where it defines sub blocking
+          as {}, e.g. force scalar context when calling sub blocking
+          (in IO::Socket::SSL::write)
+          see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=383106
+v1.0
+       - fix depreciated and practically undocumented function 
+          get_peer_certificate so that LWP Net::HTTPS works again
+        - set arg 'Blocking' while calling SUPER::configure only
+          if it was set by the caller to work around Problem in LWP
+          Net::HTTPS
+v0.999
+       - If SSL_cipher_list is not given it uses the openssl
+         default instead of setting it to 'ALL:!LOW:!EXP' like
+         before. The old value included ADH and this might be
+         a bad idea, see BUGS why.
Comment 1 Robin Norwood 2006-09-27 22:30:24 EDT
Warren has built a new package for us - since he's going out of town, I'll take
this bug over and see about getting it pushed into fc6.
Comment 2 Robin Norwood 2006-09-28 13:32:37 EDT
This has been accepted for fc6 - closing.

Note You need to log in before you can comment on or make changes to this bug.