Bug 206797 - Rhythmbox doesn't detect audio CD
Rhythmbox doesn't detect audio CD
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-16 15:43 EDT by Christophe Lambin
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-31 17:39:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of 'rhythmbox -d' (793.72 KB, text/plain)
2006-09-16 15:43 EDT, Christophe Lambin
no flags Details

  None (edit)
Description Christophe Lambin 2006-09-16 15:43:38 EDT
Description of problem:
If I mount an audio CD, rhythmbox doesn't detect it. Even running 'Scan
Removeable Media' does not detect the CD.


Version-Release number of selected component (if applicable):
rhythmbox-0.9.4.1-1.fc5.1

How reproducible:
Always


Steps to Reproduce:
1. Start rhythmbox
2. Mount audio CD
3. Select Music -> Scan Removeable Media
  
Actual results:
Audio CD isn't detected.

Expected results:
Audio CD should be detected in either step 2 or 3.

Additional info:
Comment 1 Christophe Lambin 2006-09-16 15:43:39 EDT
Created attachment 136443 [details]
Output of 'rhythmbox -d'
Comment 2 Bastien Nocera 2007-01-30 10:52:56 EST
It seems your system isn't running the "messagebus", or the "haldaemon" service:

(21:33:40) [0x9f93890] [rb_removable_media_manager_mount_volume]
rb-removable-media-manager.c:647: Unhandled media

** (rhythmbox:11526): WARNING **: Could not initalize the HAL context: (null)

** (rhythmbox:11526): WARNING **: hal_initialize failed: (null)

** (rhythmbox:11526): WARNING **: hal_initialize failed: (null)

Could you please check whether the same thing occurs with Rhythmbox 0.9.6 that
was uploaded to the FC6 updates recently?

(Multimedia stuff moves quickly, and it would be better using the latest
distribution to use Rhythmbox properly).
Comment 3 Christophe Lambin 2007-01-31 17:39:35 EST
You're right: this was due to haldaemon not running (I had disabled that due to
another bug, which does not seem to happen anymore in FC6).

Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.