Bug 206802 - spliting firefox package in binary and libraries
spliting firefox package in binary and libraries
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-16 16:42 EDT by Dams
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-08 19:33:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dams 2006-09-16 16:42:28 EDT
The firefox package hold the /usr/bin/firefox file, and all the firefox libraries.

On FC5, non-mozilla gecko-based browsers used to linked against mozilla which
was splitted into several packages. Now that they are linked against firefox,
x86_64 systems dont have the possibility anymore to have an i386 browser for
binary-only plugins (flash, java sun, etc...) because both firefox.i386 and
firefox.x86_64 are installed and because firefox.x86_64 has the /usr/bin/firefox
binary. To remove firefox.x86_64 we would need to remove some *other* x86_64
packages

That's why spliting the firefox package (e.g: into firefox and firefox-libs)
would make things quite easier for people.

What do you think ?
Comment 1 Matthew Miller 2007-04-06 13:35:03 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 2 Christopher Aillon 2007-04-08 19:33:52 EDT
This isn't going to happen.  The libraries always have been installed in the
same RPM as the binaries and that isn't going to change.  Especially not for a
previous release where RPMs are possibly dependent on the existing behavior.

Note You need to log in before you can comment on or make changes to this bug.