Bug 206823 - Shatter gun leads to rafkill segfault
Shatter gun leads to rafkill segfault
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rafkill (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
http://sourceforge.net/tracker/index....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-16 19:42 EDT by Jerry James
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 16:15:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jerry James 2006-09-16 19:42:19 EDT
Description of problem:
If you acquire a shatter gun in rafkill, the second something is hit with fire
from the shatter gun, rafkill segfaults.  This bug has been reported to the
author via the sourceforge bug report page, with no response so far.  See the
URL provided.

Version-Release number of selected component (if applicable):
rafkill-1.2.2-1.fc5

How reproducible:
Always

Steps to Reproduce:
1. Play a very easy game to accumulate money quickly
2. Buy a shatter gun
3. Try to shoot something with the shatter gun
  
Actual results:
Rafkill segfaults

Expected results:
Normal gameplay

Additional info:
Here is a backtrace from a core file after such a crash.
#0  0x0809bf45 in Shatter::Died (this=0xb7c27d38, check=0xb7e1b9e8,
    explr=0xbf9f62a8, ME=100)
    at
/usr/lib/gcc/i386-redhat-linux/4.1.1/../../../../include/c++/4.1.1/ext/new_allocator.h:104
104           { ::new(__p) _Tp(__val); }
(gdb) bt
#0  0x0809bf45 in Shatter::Died (this=0xb7c27d38, check=0xb7e1b9e8,
    explr=0xbf9f62a8, ME=100)
    at
/usr/lib/gcc/i386-redhat-linux/4.1.1/../../../../include/c++/4.1.1/ext/new_allocator.h:104
#1  0x0807fdcc in Logic::checkCollision (this=0xbf9f62a8, fight=0xbf9f38cc,
    take=0xb7e1b9e8, sound=11, vol=12) at build/logic.cpp:245
#2  0x08080299 in Logic::runCycle (this=0xbf9f62a8, player=0xb7e1b9e8,
    level=0xbf9f6444) at build/logic.cpp:52
#3  0x0808b97c in playLevel (player=0xb7e1b9e8) at build/raptor.cpp:812
#4  0x080922e8 in rafkill (argc=1, argv=0xbf9f6a54) at build/raptor.cpp:984
#5  0x08080482 in main (argc=-1212000968, argv=0x40800000) at build/main.cpp:6

Running with strace shows this message:
write(2, "Shutting down Allegro due to sig"..., 40Shutting down Allegro due to
signal #11
) = 40

which hints that the crash may actually be in the Allegro library somewhere.
Comment 1 Hans de Goede 2006-09-20 16:15:05 EDT
Thanks for reporting this,

this is fixed in 1.2.2-3 which should show up on a mirror near you soon.

Note You need to log in before you can comment on or make changes to this bug.