Bug 206832 - Gnome and KDE install without working cursor; mouse seems ok, but useless without cursor.
Gnome and KDE install without working cursor; mouse seems ok, but useless wit...
Status: CLOSED DUPLICATE of bug 204599
Product: Fedora
Classification: Fedora
Component: xorg-x11-drivers (Show other bugs)
6
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-16 22:49 EDT by Creigh Shank
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-26 08:00:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Creigh Shank 2006-09-16 22:49:59 EDT
Description of problem:
Gnome and KDE install without working cursor; mouse seems ok, but no cursor.

Version-Release number of selected component (if applicable):
Current stable release

How reproducible:
Every time.

Steps to Reproduce:
1.Install fedora
2.
3.
  
Actual results:
Gnome and KDE install without working cursor; mouse seems ok, but no cursor.

Expected results:
Working mouse & cursor

Additional info:
Comment 1 Adam Jackson 2006-10-04 11:21:51 EDT
Please attach your Xorg.0.log and xorg.conf files from an affected setup.
Comment 2 Matěj Cepl 2006-11-01 08:20:50 EST
Maybe DUP of bug 204599?
Comment 3 Matěj Cepl 2006-11-01 10:37:14 EST
Creigh, do you have switched on compix (i.e., System/Preferences/Desktop Effects
is on)? If yes, could you, please, try to reproduce the bug with this setting
switcehd off? Thank you.
Comment 4 Samuel Sieb 2006-11-04 14:33:14 EST
I saw this on FC5 as well.  No compiz, no console switching.  I think all
systems were using the NVIDIA driver.  In the latest case with FC6, initial
install had a working cursor.  After installing the NVIDIA driver and rebooting,
it was still working.  Then the user installed all pending updates and rebooted.
 After that, the cursor was missing.
Comment 5 shmuel siegel 2006-12-01 04:57:59 EST
The same thing happened to me on my amd 3800 x2. Everything worked until I
installed the NVIDIA driver from livna. Uninstalling the NVIDIA driver didn't
fix the problem.
Comment 6 shmuel siegel 2006-12-01 07:44:44 EST
A workaround that works for me. If I turn off grub's booting with the gui I get
the cursor to work. It doesn't go away after I do ctrl-alt-f1
Comment 7 Matěj Cepl 2006-12-14 09:45:01 EST

*** This bug has been marked as a duplicate of 204599 ***
Comment 8 Samuel Sieb 2007-06-26 00:17:04 EDT
I'd like to get this reopened as I'm seeing it with nvidia chipsets, not i810. 
I did a clean install of 32-bit F7 on an Athlon64 X2.  The important part seems
to be that's it's an integrated nvidia graphics chipset.  This has only happened
for me on the integrated chipsets, not the standalone cards.  It didn't matter
if it was using the nv driver or the nvidia one.  Both drivers required the
hardware cursor to be turned off.  I don't have access to this computer any
more, but I have a friend with the same problem.  He installed FC6 and I helped
him turn off the hardware cursor.  He just upgraded to F7 now and the problem
reappeared, he had to turn it off again.
Comment 9 Samuel Sieb 2007-06-26 01:42:03 EDT
Further info from my friend after I explained how to turn the hardware cursor off:
Thanks, got it working now.  The strange thing is that the cursor
showed up when first booted, but would disappear whenever logging the
first user off and logging on again, even if the same user logged back
on.
Comment 10 Matěj Cepl 2007-06-26 08:03:16 EDT
Sorry, getting lost in our bugzilla. Samuel, can I ask you to file a new bug for
this -- refer to this bug as previous case, but I would love to have you as
reporter of the bug (I cannot switch reporters with the old bug). Don't forget
to attach as separate uncompressed attachments /etc/X11/xorg.conf and
/var/log/Xorg.0.log of the system affected by this bug and try to run X without
any /etc/X11/xorg.conf whatsoever -- what will be the results? Thanks a lot.

*** This bug has been marked as a duplicate of 204599 ***

Note You need to log in before you can comment on or make changes to this bug.