This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 206850 - system crashes with compiz on rv350 cards
system crashes with compiz on rv350 cards
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-17 04:22 EDT by Thorsten Leemhuis
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-11 13:47:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2006-09-17 04:22:13 EDT
Description of problem:
I have two systems with r300-based graphic chipsets. One is and i386 notebook with
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon
9600 M10]
01:00.0 0300: 1002:4e50

the other one a x86_64 desktop machine with
02:00.0 VGA compatible controller: ATI Technologies Inc RV350 AP [Radeon 9600]
02:00.0 0300: 1002:4150

I'm running rawhide since two weeks on both machines (updated via yum from FC5).
I enabled dri and started gnome and everything worked fine. Later I enabled
compiz and it worked fine, too -- on both machines. I logged in and out some
times and it still worked.

But after a reboot the whole machines locks up after logging into gnome via gdm
in 75% of the cases *on the first log in*. Loggin in and out after the first log
in fails only in round about 15% of the cases. And the system only lock up in 15
% of the cases on the first login if I do this:
- start the system into runlevel 5 with dri enabled
- disable dri in xorg.conf from a console
- log into gdm; gnome starts without window decorations/window manager; wait
until everything has loaded and the buffers are filed
- enable dri in xorg.conf from console
- kill X with CTRL - ALT - BACKSPACE
- log in via GDM -> gnome starts with compiz and all the effects
 

Version-Release number of selected component (if applicable):
$ rpm -q compiz xorg-x11-drv-ati kernel mesa-libGL
compiz-0.0.13-0.25.20060817git.fc6
xorg-x11-drv-ati-6.6.2-1.fc6
kernel-2.6.17-1.2630.fc6
kernel-2.6.17-1.2647.fc6
mesa-libGL-6.5.1-0.rc2.fc6
otherwise rawhide up2date as of today

Additional info:
I know this isn't a proper bug report yet. But could somebody tell me where to
look further for the root of this problem? Or is this just another "r300 dri
isn't perfect yet" issues?
Comment 1 Thorsten Leemhuis 2006-09-21 01:32:54 EDT
Found a better way to circumvent the problem in 85% of the cases -- start GNOME
with metacity enabled and enable compiz afterwards when all the buffers are
filled and the system is otherwise idle (the system still locks up in 15% of the
cases shortly after I hit "enable windows effects"). (Note: percentages only
wild guesses)
Comment 2 Thorsten Leemhuis 2006-10-11 13:47:34 EDT
Seems to be a lot better know. Thx guys for all your hard work!

Note You need to log in before you can comment on or make changes to this bug.