Bug 206855 - yum does not install dependencies (with turkish locale)
yum does not install dependencies (with turkish locale)
Status: CLOSED DUPLICATE of bug 206853
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-17 05:48 EDT by Sertaç Ö. Yıldız
Modified: 2014-01-21 17:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-17 06:24:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sertaç Ö. Yıldız 2006-09-17 05:48:00 EDT
Description of problem:

With turkish locale yum does not add the dependencies of packages to
install/update to transaction set.

Version-Release number of selected component (if applicable):

# rpm -qa gtk2{,-devel} yum\*
gtk2-devel-2.10.3-1.fc6
yum-metadata-parser-1.0-7.1.fc6
yum-2.9.6-1
gtk2-2.10.3-1.fc6
yum-updatesd-2.9.6-1
yum-utils-0.6-5.fc6

How reproducible:
everytime

Steps to Reproduce:
1. choose a package with dependencies to update/install
2. "LANG=en_US.UTF-8 yum update <package>" works
3. "LANG=tr_TR.UTF-8 yum update <package>" does not.
  
Actual results:

# LANG=tr_TR.UTF-8 yum --noplugins -d 10 -e 10 update gtk2
Yum Version: 2.9.6
COMMAND: yum --noplugins -d 10 -e 10 
Installroot: /
Ext Commands:

   gtk2
Setting up Update Process
Setting up repositories
livna-development         100% |=========================|  951 B    00:00     
extras-development        100% |=========================| 1.1 kB    00:00     
development               100% |=========================| 1.1 kB    00:00     
Reading repository metadata in from local files
Setting up Package Sacks
Reading Local RPMDB
Building updates object
putting gnutls in simple update
[...snipped...]
putting java-1.4.2-gcj-compat in simple update
processing kernel-devel.i686
[...snipped...]
processing kernel.i686
Resolving Dependencies
1158484507.43
--> Populating transaction set with selected packages. Please wait.
Member: gtk2.i386 0-2.10.3-6.fc6 - u
Adding Package gtk2 - 2.10.3-6.fc6.i386 in mode u
---> Package gtk2.i386 0:2.10.3-6.fc6 set to be updated
--> Running transaction check
# of Deps = 1

Dep Number: 1/1

gtk2-devel requires: gtk2 = 2.10.3-1.fc6
--> Processing Dependency: gtk2 = 2.10.3-1.fc6 for package: gtk2-devel
Looking for ('gtk2', 'EQ', ('0', '2.10.3', '1.fc6')) as a requirement of
gtk2-devel - 2.10.3-1.fc6.i386
Requiring package gtk2-devel-2.10.3-1.fc6 not in transaction set nor in rpmdb
miss = 1
conf = 0
CheckDeps = 0
--> Finished Dependency Resolution
Dependency Process ending
Error: Requiring package gtk2-devel-2.10.3-1.fc6 not in transaction set nor in rpmdb

Expected results:

# LANG=en_US.UTF-8 yum --noplugins update gtk2
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gtk2.i386 0:2.10.3-6.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: gtk2 = 2.10.3-1.fc6 for package: gtk2-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package gtk2-devel.i386 0:2.10.3-6.fc6 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 gtk2                    i386       2.10.3-6.fc6     development       6.4 M
Updating for dependencies:
 gtk2-devel              i386       2.10.3-6.fc6     development       2.8 M

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       2 Package(s)         
Remove       0 Package(s)         

Total download size: 9.2 M
Is this ok [y/N]: y


Additional info:

Observing this only in turkish locale, I think it's another i/I case folding
bug. I guess yum cannot see the dependencies are 'i'nstalled, but I couldn't
spot the problem after a quick peek to yum sources. The bug might as well be in
the libraries yum use.

This behavior started with the yum version that had broken installonlyn plugin,
if it helps.
Comment 1 Sertaç Ö. Yıldız 2006-09-17 06:24:23 EDT
sorry for the spam...

*** This bug has been marked as a duplicate of 206853 ***

Note You need to log in before you can comment on or make changes to this bug.