Bug 206860 - GTK+ icon cache "bugs" on ScriptletSnippets
GTK+ icon cache "bugs" on ScriptletSnippets
Status: CLOSED NOTABUG
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora Websites Team
Karsten Wade
:
Depends On:
Blocks: 170335 206650
  Show dependency treegraph
 
Reported: 2006-09-17 07:54 EDT by Marcin Garski
Modified: 2009-08-05 14:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 13:46:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marcin Garski 2006-09-17 07:54:43 EDT
On http://fedoraproject.org/wiki/Packaging/ScriptletSnippets -> GTK+ icon cache
section should look something like this:
if [ -x %{_bindir}/gtk-update-icon-cache ]; then
        if [ -f %{_datadir}/icons/hicolor/index.theme ]; then
                touch --no-create %{_datadir}/icons/hicolor || :
                %{_bindir}/gtk-update-icon-cache --quiet
%{_datadir}/icons/hicolor || :
        fi
fi

If we don't check if %{_datadir}/icons/hicolor/index.theme exist it will cause
bug #206650
Comment 1 Karsten Wade 2006-09-17 13:41:54 EDT
The best way to fix a problem on a Wiki page is to get an account and fix the
page.  The people who wrote and maintain that page should be watching for any
changes, and they can discuss any questions they have directly with you.

I'll leave this report open to confirm that you are able to obtain a Fedora
account and edit the Wiki.  For account information:

http://fedoraproject.org/wiki/Infrastructure/AccountSystem
Comment 2 Michael Schwendt 2006-09-17 14:24:03 EDT
Nice in theory, but doesn't apply to this Wiki. The "Packaging" hierarchy
is immutable via ACLs. It belongs to the Packaging Comittee, who are the
only ones who can edit these pages.

Discussing the proposed changes on fedora-packaging list seems the
only way.

Alternatively, get them to create a freely editable _draft_ version
of the document, which everybody can edit and which is monitored by
the committee.
Comment 3 Marcin Garski 2006-09-22 06:56:30 EDT
I've mailed fedora-packaging list
(http://www.redhat.com/archives/fedora-packaging/2006-September/msg00125.html)
Comment 4 Marcin Garski 2006-10-31 16:27:39 EST
Draft on fedoraproject.org:
http://fedoraproject.org/wiki/PackagingDrafts/ScriptletSnippets/iconcache
Comment 5 Nicolas Mailhot 2006-11-01 05:36:15 EST
My reading of the f.d.o icon spec is highcolor is the default fallback theme, so
if any icon spec tool such as gtk-update-icon-cache is present on the system,
highcolor must be installed

So I'd tend to think this is a missing R on highcolor-theme in the gtk2 package,
not a snippet problem
Comment 6 Rex Dieter 2006-11-01 08:04:10 EST
While I agree with Nicolas, but doesn't bug #206650 cite the lack of index.theme
under *locolor* not hicolor theme?
Comment 7 Rex Dieter 2006-11-01 08:11:17 EST
In the meantime, imo, the simplest workaround is to simply ignore
gtk-update-cache's output, and use this

%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor 2>/dev/null || :
Comment 8 Matthias Clasen 2006-11-01 10:31:53 EST
the proposed change does not seem to bare any relation to the issue in bug 206650.
the -x /usr/bin/gtk-update-icon-cache check is enough for hicolor, since the
package that provides the binary (gtk2) requires hicolor-icon-theme.
Comment 9 Rex Dieter 2006-11-28 13:46:07 EST
Good points all, and I'll make sure suggestions get incoporporated into the next
iteration of policy discussed in future packaging committee meetings.

Regardless, this isn't something the docs or websites teams can/should address,
so I'll close this bug.
Comment 11 eric@christensenplace.us 2009-08-05 14:42:46 EDT
Tickets move to docs-request so the fedora-websites component can be removed per request from Ricky.

Note You need to log in before you can comment on or make changes to this bug.