Bug 206865 - gnome-mount crashes after DVD-RAM is inserted into drive
gnome-mount crashes after DVD-RAM is inserted into drive
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-mount (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-09-17 08:46 EDT by Vladimir Kotal
Modified: 2013-03-05 22:47 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 11:52:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vladimir Kotal 2006-09-17 08:46:10 EDT
Description of problem:
gnome-mount crashes after DVD-RAM is inserted into drive


Version-Release number of selected component (if applicable):
gnome-mount-0.4-5

How reproducible:
insert DVD-RAM into drive, wait for gnome-mount to crash

Steps to Reproduce:
1.log into the Fedora system
2.insert DVD-RAM into drive
  
Actual results:
gnome-mount crashes

Expected results:
the medium should be mounted

Additional info:

related process list just after the crash

[techie@erazim ~]$ ps axww|grep mount
 2176 ?        Ss     0:00 /usr/sbin/automount --timeout=60 /net program
/etc/auto.net
 3022 ?        S      0:00 /usr/bin/gnome-mount
--hal-udi=/org/freedesktop/Hal/devices/volume_part_1_size_4580769792
 3023 ?        Ss     0:00 /usr/bin/gnome-mount
--hal-udi=/org/freedesktop/Hal/devices/volume_part_1_size_4580769792
 3024 ?        S      0:00 /usr/libexec/gnome_segv gnome-mount 11 0.4
 3027 pts/1    R+     0:00 grep mount
[techie@erazim ~]$
Comment 1 Vladimir Kotal 2006-09-17 08:48:37 EDT
I have tried to get stacktrace:

[root@erazim techie]# ps axww|grep mount
 2176 ?        Ss     0:00 /usr/sbin/automount --timeout=60 /net program
/etc/auto.net
 1371 ?        S      0:00 /usr/bin/gnome-mount
--hal-udi=/org/freedesktop/Hal/devices/volume_part_1_size_4580769792
 1372 ?        Ss     0:00 /usr/bin/gnome-mount
--hal-udi=/org/freedesktop/Hal/devices/volume_part_1_size_4580769792
 1373 ?        S      0:00 /usr/libexec/gnome_segv gnome-mount 11 0.4
 1377 pts/1    S+     0:00 grep mount
[root@erazim techie]# pstack 1372
#0  0x00cad402 in __kernel_vsyscall ()
#1  0x0026cbe3 in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x06095e26 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x0804c32f in ?? ()
#5  0x0804cdb4 in ?? ()
#6  0x00ce0724 in __libc_start_main () from /lib/libc.so.6
#7  0x0804a6c1 in ?? ()
[root@erazim techie]# pstack 1371
#0  0x00cad402 in __kernel_vsyscall ()
#1  0x0026bd33 in __read_nocancel () from /lib/libpthread.so.0
#2  0x0804ccb3 in ?? ()
#3  0x00ce0724 in __libc_start_main () from /lib/libc.so.6
#4  0x0804a6c1 in ?? ()
[root@erazim techie]# 


Let me know if you need more info, the problem is fully reproducible.
Comment 2 David Zeuthen 2006-09-26 13:54:32 EDT
Hi, please try with hal-0.5.8 and gnome-mount 0.5 available from here

 http://people.freedesktop.org/~david/hal-0.5.8.1-fc6/

Thanks.
Comment 3 Vladimir Kotal 2006-09-28 10:07:51 EDT
I would rather not tinker with the system more than needed since:

[root@erazim hal-gnome-mount]# rpm -Uvh hal-0.5.8.1-0davidz1.i386.rpm 
error: Failed dependencies:
        dbus >= 0.90 is needed by hal-0.5.8.1-0davidz1.i386
        dbus-glib >= 0.70 is needed by hal-0.5.8.1-0davidz1.i386
        libdbus-1.so.3 is needed by hal-0.5.8.1-0davidz1.i386
        libvolume_id.so.0 is needed by hal-0.5.8.1-0davidz1.i386
        rtld(GNU_HASH) is needed by hal-0.5.8.1-0davidz1.i386
        udev >= 089-1 is needed by hal-0.5.8.1-0davidz1.i386

I will try FC6 once it is released and see if it still crashes.
Comment 4 David Zeuthen 2006-09-28 11:52:09 EDT
It's in Rawhide already and will be part of FC6. Please reopen if you can
reproduce this bug.

Note You need to log in before you can comment on or make changes to this bug.