Bug 2068883 - Creating a storage pool constantly block with message "Target path should not be empty"
Summary: Creating a storage pool constantly block with message "Target path should no...
Alias: None
Product: Fedora
Classification: Fedora
Component: cockpit-machines
Version: 36
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Simon Kobyda
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2022-03-27 08:47 UTC by Peter Boy
Modified: 2023-01-30 16:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2023-01-30 16:03:02 UTC
Type: Bug

Attachments (Terms of Use)

Description Peter Boy 2022-03-27 08:47:41 UTC
Description of problem:
After Installation of cockpit-machines (264-1.fc36) there is no storage pool defined, of course.

Trying to create a new storage pool using /var/lib/libvirt/boot or /var/lib/libvirt/images as created by libvirt installation always end in an error message "Target path should not be empty", regardless if there are files in the directory of not.

In the previous versions that worked flawlessly. 

Version-Release number of selected component (if applicable):

cockpit-machines-264-1.fc36.noarch on Fedora Server F36 beta 1.4 

How reproducible:

Steps to Reproduce:
1. Install Fedora Server F36 beta 1.4
2. Install "dnf install qemu-kvm-core libvirt virt-install cockpit-machines"
3. Try to create a storage pool e.g. "Installation media" in /var/lib/libvirt/boot 

Actual results:

Error message "Target path should not be empty" blocks creating the pool whether  there are files in the subdir or not. 

Expected results:

A storage pool should be created.

Additional info:

Worked without issues wich previous versions.

Comment 1 Katerina Koukiou 2023-01-30 16:03:02 UTC
@Peter Boy, missed replying here on time. I can't reproduce this with latest available cockpit-machines (282).

If you can still reproduce it please update the issue with more details ex:

do you copy paste or ue keyboard to type the pool target?
does the issue persist if you change the order that you fill in the fields?

Note You need to log in before you can comment on or make changes to this bug.