Bug 206917 - ifconfig does not show the full interface name
ifconfig does not show the full interface name
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-tools (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Ben Levenson
:
: 252017 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-18 01:50 EDT by Lumir
Modified: 2010-10-22 02:03 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0691
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:36:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
trim_iface (1.29 KB, patch)
2007-02-01 06:22 EST, Jose Plans
no flags Details | Diff

  None (edit)
Description Lumir 2006-09-18 01:50:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 2.0.50727; .NET CLR 1.1.4322)

Description of problem:
This problem is related to ifconfig limitation which show only first 9 characters of network interface name.

We created the bond0 interface tagged with VLAN 103. The name of the interface was bond0.103 that have 9 characters total. Then we created aliases to this interface but ifconfig still showed only the bond0.103 name without :0, :1 supplements to aliases IPs.

Version-Release number of selected component (if applicable):
net-tools-1.60-37.EL4.6

How reproducible:
Always


Steps to Reproduce:
1.Create network interface with name longer than 9 characters
2.Run ifconfig
3.

Actual Results:
bond0.103 Link encap:Ethernet  HWaddr 00:13:72:69:FE:FE
          inet addr:10.0.3.4  Bcast:10.0.3.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MASTER MULTICAST  MTU:1500  Metric:1

Expected Results:
bond0.103:1 Link encap:Ethernet  HWaddr 00:13:72:69:FE:FE
          inet addr:10.0.3.4  Bcast:10.0.3.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MASTER MULTICAST  MTU:1500  Metric:1

Additional info:
Comment 2 Jose Plans 2007-02-01 06:22:04 EST
Created attachment 147095 [details]
trim_iface

This should fix the problem. Patch from Rawhide.
Comment 7 Radek Vokal 2008-01-03 04:44:43 EST
*** Bug 252017 has been marked as a duplicate of this bug. ***
Comment 13 errata-xmlrpc 2008-07-24 15:36:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0691.html

Note You need to log in before you can comment on or make changes to this bug.