Bug 206922 - libgcc_s.so.1 required by /usr/lib/libstdc++.so.6 complains about missing GCC_4.2.0
libgcc_s.so.1 required by /usr/lib/libstdc++.so.6 complains about missing GCC...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gcc (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-18 04:37 EDT by Alexander Boström
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 04:45:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Boström 2006-09-18 04:37:14 EDT
Description of problem:
There seems to be some kind of regression in the latest gcc 3 package in
RHEL4.4. A third-party application (Abaqus) which worked previously on RHEL4 now
fails to link properly on Update 4:

/usr/local/vol/abaqus/6.5-1/cae/exec/ABQcaeK.exe:
/usr/local/vol/abaqus/6.5-1/cae/External/libgcc_s.so.1: version `GCC_4.2.0' not
found (required by /usr/lib/libstdc++.so.6)
ABAQUS Error: ABAQUS/CAE Kernel exited with an error.

Version-Release number of selected component (if applicable):
libstdc++ from gcc-3.4.6-3.src.rpm

How reproducible:
Always.

Additional info:

A workaround exists, replacing the libgcc_s.so.1 provided by the application and
instead using /lib/libgcc_s.so.1 from the OS distribution.

A web search reveals other applications with the same problem, like Ensim
http://forum.ensim.com/showthread.php?t=16882 and also similar problems on FC5.
Comment 1 Jakub Jelinek 2006-09-18 04:45:36 EDT
That's Abaqus' fault, it shouldn't override the system libgcc_s with their own,
at least not if it doesn't override all toolchain libs.
So please report this to the third party vendor instead.
There is nothing we can do about this.

Note You need to log in before you can comment on or make changes to this bug.