Bug 206923 - Automatic removal of dependencies
Automatic removal of dependencies
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-18 04:51 EDT by Rahul Sundaram
Modified: 2013-03-13 01:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 13:07:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2006-09-18 04:51:43 EDT
Description of problem:

If package X is removed, the dependencies installed for X is not always removed.

Expected results:

Apt-get has --purge and Synpatic apparently now exposes this better. We should
look at implementing something similar in Pirut. I know this was discused in
yum-devel lists before and was rejected as a core feature but this seems quite
useful neverthless. 

Additional info:

https://launchpad.net/distros/ubuntu/+source/synaptic/+bug/23036
Comment 1 Jeremy Katz 2006-09-18 13:07:46 EDT
The problem is there's no way to know if a package was explicitly selected for
installation or if it was just pulled in by deps.  

So doing something like this in an automated fashion is an _extremely_ bad idea.
 For people that want to micromanage things like this, there's the --leaves
option to package-cleanup in yum-utils

Note You need to log in before you can comment on or make changes to this bug.