Bug 206927 - use multi-arch yum repos instead of multilib x86_64 trees
use multi-arch yum repos instead of multilib x86_64 trees
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-18 05:16 EDT by Jens Petersen
Modified: 2014-03-16 23:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 16:42:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2006-09-18 05:16:03 EDT
Description of problem:
I suggest dropping i386 packages from x86_64 trees in the next release.
It would be simpler just to use separate yum repos for x86_64 and i386.
Current fc6 x86_64 seems seems to multilib a large part of the distro.

Additional info:
On my main machine running x86_64 fc5 I current added updates-i386,
extras-i386 (and livna-i386) repos and it seems to work just fine.
Comment 1 Jesse Keating 2006-09-18 09:11:42 EDT
I'm pretty certain that there would be some conflicts if this were done.  not to
mention that the CD size for x86_64 would double to 10 CDs, entirely way too much.

Bill, any thoughts?
Comment 2 Bill Nottingham 2006-09-18 13:41:56 EDT
I think it's probably too late for FC6 to do this. It will lead to conflicts in
the repo itself post-install; if the user never tries to install certain
packages, they won't hit, but they will be there.
Comment 3 Jeremy Katz 2006-09-18 13:53:20 EDT
Yeah, there are lots of dragons in doing this -- there are packages which aren't
multiarch safe and so trying to do this will just cause conflicts for users.
Comment 4 Jon Stanley 2008-05-12 17:32:36 EDT
Is this worth even attempting?  My vote is no.  As far as space on the mirrors,
the content is hardlinked, so that's moot. There just seems to be more heartache
and pain here than it's worth to me.
Comment 5 Bill Nottingham 2008-05-12 20:18:21 EDT
To do this properly requires doing multilib (essentially) via a yum plugin of
some sort. It hasn't been tried yet.
Comment 6 John Poelstra 2008-07-03 19:40:10 EDT
triaged
Comment 7 Bill Nottingham 2008-12-01 16:42:59 EST
For now, we're not doing this.

Note You need to log in before you can comment on or make changes to this bug.