Bug 2069277 - Cannot scan anything with Simple Scan after upgrading F35 -> F36
Summary: Cannot scan anything with Simple Scan after upgrading F35 -> F36
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: sane-airscan
Version: 36
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://ask.fedoraproject.org/t/commo...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-03-28 16:01 UTC by Michael Catanzaro
Modified: 2022-05-16 13:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-28 17:31:41 UTC
Type: Bug


Attachments (Terms of Use)

Description Michael Catanzaro 2022-03-28 16:01:42 UTC
Description of problem: After upgrading from F35 -> F36, I can no longer scan anything with Simple Scan. When I click the Scan button, it displays a dialog with the error message "Failed to scan: Unable to connect to scanner"


Version-Release number of selected component (if applicable): simple-scan-40.7-2.fc36, sane-airscan-0.99.27-2.f36


How reproducible: Always


Steps to Reproduce:
1. Turn on HP OfficeJet 4630 printer
2. Open Simple Scan
3. Press "Scan"

Actual results: "Failed to scan: Unable to connect to scanner"


Expected results: It should scan stuff


Additional info: I originally reported this in bug #2066528, but I'm splitting it into a separate bug report because I'm no longer confident that it's the same issue. Zdenek requested addition debug info in comment 4 of that bug, and I will attempt to provide it next.

Comment 1 Michael Catanzaro 2022-03-28 16:08:14 UTC
> Hmm... can you check the printer settings on the device whether scanning settings are all enabled? According sane-airscan README, the device should support eSCL, so it would be great if you checked if all scanning connected settings are enabled on the device.

I don't think my printer has any scanner-related settings on the device, at least not that I can find.  The only available preferences are things like language, date and time, country/region, sound volume... nothing related to scanning.

> Once you verify that, please follow the steps for debugging sane-airscan[1], debugging discovery[2] and scanning process[3] via scanimage for now and attach the requested files.


Coming right up. I will attach my sane-airscan log privately because I see it contains IPv6 addresses.

Comment 3 Michael Catanzaro 2022-03-28 16:12:55 UTC
Actually wait, sorry. I just noticed that I actually have two options for scanners in Simple Scan:

HP OfficeJet 4630 series
eSCL HP OfficeJet 4630 series [3DF5DF] (USB)

The first one doesn't work, but the second one works fine. You tried to tell me this back in bug #2066528:

> For scanning, sane-airscan should automatically kick in - are you sure there isn't another device in Simple Scan dialog, where you choose the device for scanning?

But somehow I failed to notice until now. So I guess probably the rest of the requested debug stuff is not actually needed?

It seems sad that the first option here does not work. Is there some manual intervention that I'm supposed to perform to fix this, similar to the need to remove the permanent print queue after updating to F36? Or is this just a bug?

Comment 4 Zdenek Dohnal 2022-03-28 17:31:41 UTC
(In reply to Michael Catanzaro from comment #3)
> Actually wait, sorry. I just noticed that I actually have two options for
> scanners in Simple Scan:
> 
> HP OfficeJet 4630 series
> eSCL HP OfficeJet 4630 series [3DF5DF] (USB)
> 
> The first one doesn't work, but the second one works fine. You tried to tell
> me this back in bug #2066528:
> 
> > For scanning, sane-airscan should automatically kick in - are you sure there isn't another device in Simple Scan dialog, where you choose the device for scanning?
> 
> But somehow I failed to notice until now. So I guess probably the rest of
> the requested debug stuff is not actually needed?

Yup, not needed anymore - I'm glad it works for you :) driverlessly :) .

> 
> It seems sad that the first option here does not work. Is there some manual
> intervention that I'm supposed to perform to fix this, similar to the need
> to remove the permanent print queue after updating to F36? Or is this just a
> bug?

The first entry is from hpaio backend, from hplip - so it suffers the same issue as 'hp' printing backend - it tries to connect on USB port, which is taken by ipp-usb.

Removing the entry can be done either by removing hplip (which should get libsane-hpaio uninstalled) or by modifying (by commenting out the line)/removing /etc/sane.d/dll.d/hpaio file. Because every scanning app runs every backend one by one depending on what it can see in /etc/sane.d/dll.conf file or in /etc/sane.d/dll.d/ directory.

Comment 5 Zdenek Dohnal 2022-03-28 17:33:34 UTC
'Because every scanning app runs every backend one by one depending on what it can see in /etc/sane.d/dll.conf file or in /etc/sane.d/dll.d/ directory.' and the hpaio backend still can see the device, but cannot connect to it, so until you remove hplip or hpaio from sane configs, the broken entry will be shown :( .

Comment 6 Michael Catanzaro 2022-03-28 17:36:27 UTC
This is rough. :/ So more manual intervention required for users upgrading from F35.

What about users installing a fresh F36? Do they have to remove hplip too?

Comment 7 Michael Catanzaro 2022-03-28 17:39:22 UTC
(In reply to Zdenek Dohnal from comment #4)
> Removing the entry can be done either by removing hplip (which should get
> libsane-hpaio uninstalled)

Looks like hplip is not a dependency of libsane-hpaio. I have now removed both of them.

I assume we're going to have a lot more bug reports and complaints once F36 is released. :/

Comment 8 Zdenek Dohnal 2022-03-28 18:04:57 UTC
(In reply to Michael Catanzaro from comment #6)
> This is rough. :/ So more manual intervention required for users upgrading
> from F35.

Unfortunately - since you cannot count on device being turned on etc... :(

> 
> What about users installing a fresh F36? Do they have to remove hplip too?

I will make libsane-hpaio suggested in hplip.spec, so it won't be dragged in automatically in F36+ together with hplip - it can solve some reports (since ipp-usb will be there for them in case they have IPP-over-USB device).

Comment 9 Michael Catanzaro 2022-03-29 13:21:54 UTC
Proposing this for CommonBugs because after upgrade to F36, the scanner selected by default in Simple Scan is now broken, and you have to know to select a different scanner with the same name in order to scan. This design is confusing and not ideal. See also: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/BISRSRAUSMMKK34UBAGP44QL7MPZ74GI/

Comment 10 Zdenek Dohnal 2022-03-29 14:21:32 UTC
Additional note:

IIUC the default selection of the broken scanner happens because the scanner was used during the last session - once you use the other one, the dialog will make the default of it.

IMO it is unfortunate design of simple scan as well, where other devices are hidden in scroll menu - regarding device selection xsane has a clearer menu.

Comment 11 Adam Williamson 2022-05-09 23:14:29 UTC
For common bugs purposes: what actually changed here? Did something change in f36?

AFAICS, sane-airscan should have been in the default install since F32. So I'm having trouble writing an entry describing something that changed in F36.

Thanks!

Comment 12 Zdenek Dohnal 2022-05-10 06:54:42 UTC
Hi Adam,

ipp-usb's recommendation was removed from cups before F36 beta freeze, so nothing changed in the default installation - however, if someone installs the ipp-usb package, the issue will appear again.


To put it simply (at least I will try :) ) - if you have a USB device which can do a driverless scanning, you install ipp-usb and the device is supported by classic scanner driver (such hplip or sane-backends) as well, you will see two scanners on your machine, but the classic one won't work due USB conflict. This becomes a problem in applications which automatically choose the scanner which was used last time, like Simple Scan - because the default after ipp-usb installation would be the old classic scanner, which won't work.

sane-airscan gets into the picture because it provides support for driverless scanning standards, eSCL and WSD, and ipp-usb creates such driverless interface for USB devices capable of driverless scanning. So sane-airscan picks up a virtual device, which is advertised on localhost by mDNS and works with it as if it was a network device.

I've updated quick-docs here -https://pagure.io/fedora-docs/quick-docs/pull-request/450 .


Note You need to log in before you can comment on or make changes to this bug.