Bug 2069295 - Evolution preview panel is dark
Summary: Evolution preview panel is dark
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 35
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-03-28 16:35 UTC by David Horvath
Modified: 2022-04-20 19:15 UTC (History)
7 users (show)

Fixed In Version: evolution-3.42.4-2.fc35 evolution-3.40.4-5.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-04-08 20:28:48 UTC
Type: Bug


Attachments (Terms of Use)
Screenshot (90.42 KB, image/png)
2022-03-28 16:35 UTC, David Horvath
no flags Details

Description David Horvath 2022-03-28 16:35:25 UTC
Created attachment 1868805 [details]
Screenshot

Description of problem:
after latest update the preview panel background is dark gray in Fedora dark themes, but characters is dark gray too. 


Version-Release number of selected component (if applicable):
3.42.4 (3.42.4-1.fc35) 

How reproducible:


Steps to Reproduce:
1. set Fedora to dark theme
2. start evolution
3. show preview panel with plain email

Comment 1 Milan Crha 2022-03-28 16:53:10 UTC
Thanks for a bug report. It's due to webkit2gtk3 changes. It's tracked upstream as [1]. I can backport the change, as there's not planned any upstream release with the 3.42.x and older versions.

Michael, I see you made a 2.36.0 webkit2gtk3 update for f34, f35, f36 and rawhide. The related change there breaks Evolution. While it's a good change in general, it breaks user experience in stable Fedora, which can be understood as a regression by the users. There is surely not being done any upstream Evolution release for the 3.40.x, similarly as none for the 3.42.x. It's really unfortunate to break apps this way.

[1] https://gitlab.gnome.org/GNOME/evolution/-/issues/1835

Comment 2 Michael Catanzaro 2022-03-28 17:42:08 UTC
Hi Milan,

Sorry for the breakage. :/ The F35 update has already gone out. Do you want me to hold the F34 update to give you more time to react?

Comment 3 Fedora Update System 2022-03-29 06:24:49 UTC
FEDORA-2022-b375b6a0f7 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-b375b6a0f7

Comment 4 Fedora Update System 2022-03-29 06:24:52 UTC
FEDORA-2022-02900a53e7 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2022-02900a53e7

Comment 5 Milan Crha 2022-03-29 06:27:09 UTC
(In reply to Michael Catanzaro from comment #2)
> The F35 update has already gone out. Do you want me to hold the F34 update to give you more time to react?

That's okay, I just filled evo updates. They can work with older webkit2gtk3 too, thus they can get to the users also before the webkti2gtk3 update (they should go ideally together, but as the f35 is out already, it doesn't matter that much).

Comment 6 David Horvath 2022-03-29 20:27:59 UTC
I've installed with bodhi and tested it. Working fine, bug is fixed.
Thank you guys the quick fix!

David

Comment 7 Fedora Update System 2022-03-30 01:31:47 UTC
FEDORA-2022-02900a53e7 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-02900a53e7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-02900a53e7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2022-03-30 02:26:08 UTC
FEDORA-2022-b375b6a0f7 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-b375b6a0f7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-b375b6a0f7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Michael Catanzaro 2022-03-30 03:00:51 UTC
I've unset autopush on the F34 update, to ensure your update here hits stable first. Most likely, I'll wait for 2.36.1 before pushing the update to F34, because some other regressions were noticed too.

Comment 10 Milan Crha 2022-03-30 06:43:27 UTC
(In reply to Michael Catanzaro from comment #9)
> Most likely, I'll wait for 2.36.1 before pushing the update to
> F34, because some other regressions were noticed too.

Anything I should know about, make a fix on the Evolution side for?

Note the only downside here is that I fix evo, but other apps, which may or may not be affected, still are or are not affected. Of course, evo's way of using the WebKitGTK is very specific and complex. This particular theme thing was related to iframe-s and color propagation inside the iframe.

Comment 11 Michael Catanzaro 2022-03-30 15:19:32 UTC
(In reply to Milan Crha from comment #10) 
> Anything I should know about, make a fix on the Evolution side for?

Ah, no, not anything that would require changes in applications.

> Note the only downside here is that I fix evo, but other apps, which may or
> may not be affected, still are or are not affected. Of course, evo's way of
> using the WebKitGTK is very specific and complex. This particular theme
> thing was related to iframe-s and color propagation inside the iframe.

Right, but this sort of change is considered normal because web APIs are not stable. I doubt that apps other than Evolution would have been affected, though of course it's impossible to say for sure....

Comment 12 Milan Crha 2022-03-31 07:17:39 UTC
(In reply to Michael Catanzaro from comment #11)
> Ah, no, not anything that would require changes in applications.

Good. Maybe you'd be interested in this thread, which opened yesterday on the evolution-list:
https://mail.gnome.org/archives/evolution-list/2022-March/msg00096.html

Comment 13 Michael Catanzaro 2022-03-31 15:41:25 UTC
(In reply to Milan Crha from comment #12)
> Good. Maybe you'd be interested in this thread, which opened yesterday on
> the evolution-list:
> https://mail.gnome.org/archives/evolution-list/2022-March/msg00096.html

Looks like a crash that needs to be reported on WebKit Bugzilla.

Comment 14 Milan Crha 2022-04-01 06:29:27 UTC
(In reply to Michael Catanzaro from comment #13)
> Looks like a crash that needs to be reported on WebKit Bugzilla.

Okay, thanks, I'll ask the user there to report it or to provide more details.

By the way, the message mentions a missing dependency on swrast-dri.so, which can be a packaging issue, maybe.

Comment 15 Fedora Update System 2022-04-05 16:07:46 UTC
FEDORA-2022-02900a53e7 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-02900a53e7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-02900a53e7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2022-04-08 20:28:48 UTC
FEDORA-2022-b375b6a0f7 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 17 Fedora Update System 2022-04-20 19:15:34 UTC
FEDORA-2022-02900a53e7 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.