Bug 206945 - unable to select IPv6 stateless address autoconfiguration
unable to select IPv6 stateless address autoconfiguration
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-18 08:26 EDT by Subhendu Ghosh
Modified: 2016-10-04 00:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-14 14:03:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Subhendu Ghosh 2006-09-18 08:26:11 EDT
IPv6 supports Stateless Address autoconfiguration.  Anaconda requires that
either DHCP be selected or an IP address entered for an interface when selecting
"activate on boot"

Should be able to "ativate on boot" without a specific IPv6 address so long as
IPv4 is not selected.

Possibly offer separate options depending on whether it is IPv4 or IPv6
Comment 1 David Cantrell 2006-09-20 14:02:16 EDT
I want to avoid adding another check box or radio button, so maybe we can get
the desired functionality based on what check boxes the user has selected.  Let
me see if I understand this correctly.

If the user checks enable IPv6 and activate on boot, but unchecks use DHCP, then
IPv6 autoconf should be set in the sysconfig file?  Is there ever a case where
the user would have DHCP enabled for IPv6 *and* want autoconfiguration?
Comment 2 Subhendu Ghosh 2006-09-21 11:21:09 EDT
DHCP implies stateful configuration, so the case of both autoconfiguration *and*
DHCP for IPv6 should not exist.
Comment 3 David Cantrell 2006-09-21 11:24:42 EDT
That's what I thought, but I just wanted to make sure.  OK, so here's what I'll
do.  If you check 'Enable IPv6' and 'Activate on boot' but leave DHCP unchecked,
I'll enable IPv6 autoconfiguration.

Actually, that doesn't handle the case where you'd want DHCP for IPv4 and
autoconfiguration for IPv6.  Crap.  OK, let me work with the UI a bit and get
back to you on that.
Comment 4 Subhendu Ghosh 2006-09-21 22:43:44 EDT
yes - that's the rub.  You need options for both IPv4 and IPv6.  Co-mingling
options is a pain.  Other option is to leave the IPv6 autoconfiguration option
as a kickstart only feature and not an interactive install feature. Would have
to document it.
Comment 5 David Cantrell 2006-10-06 11:04:30 EDT
OK, we (me and Chris Lumens) have looked at adding this feature as a
kickstart-only feature so it can be in RHEL5 GA, but it's not possible without
changes to the loader.  It's really too late to be adding that, so we're going
to have to postpone this feature until later.

I actually prefer that because I'd like to rework the network configuration user
interfaces in the installer.  I changed them all around for FC6 to incorporate
IPv6 and I found out about address autoconfiguration too late to make any more
changes.  Rather than rush through and add that to the UI, I'd like to figure
out if there are any other things we need to add to the manual configuration
screens and get them really complete.
Comment 6 Subhendu Ghosh 2006-10-06 17:17:07 EDT
Let's just document what constrains will exist for RHEL5GA and work for it in 5.1
Comment 7 David Cantrell 2006-12-14 14:03:21 EST
This is fixed in rawhide and continues to be improved.  Independent IPv4 and
IPv6 stack configuration per interface can be done in rawhide now.

Note You need to log in before you can comment on or make changes to this bug.