Bug 2069451 - No logo on default background in dark mode
Summary: No logo on default background in dark mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell-extension-background-logo
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F36FinalBlocker F36FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2022-03-28 22:02 UTC by Máirín Duffy
Modified: 2022-04-06 13:08 UTC (History)
6 users (show)

Fixed In Version: gnome-shell-extension-background-logo-42.0-1.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-04-05 14:27:53 UTC
Type: Bug


Attachments (Terms of Use)
Screenshot showing light wallpaper has logo (295.84 KB, image/png)
2022-03-28 22:03 UTC, Máirín Duffy
no flags Details
Screenshot showing dark wallpaper has no logo (209.80 KB, image/png)
2022-03-28 22:03 UTC, Máirín Duffy
no flags Details

Description Máirín Duffy 2022-03-28 22:02:08 UTC
Description of problem:
The Fedora logo doesn't appear on the dark mode version of the default F36 wallpaper.


Version-Release number of selected component (if applicable):
gnome-shell-extension-background-logo-42~beta-1.fc36.noarch

How reproducible:
eminently

Steps to Reproduce:
1. Go to GNOME background chooser
2. Select dark version of default wallpaper

Actual results:
Logo disappears from lower right corner


Expected results:
Logo appears in lower right corner


Additional info:

Comment 2 Máirín Duffy 2022-03-28 22:03:54 UTC
Created attachment 1868854 [details]
Screenshot showing dark wallpaper has no logo

Comment 3 Máirín Duffy 2022-03-29 17:12:04 UTC
mclasen pointed out we might want to use a different version of the logo for contrast against the dark mode background.

In fedora-logos we ship /usr/share/fedora-logos/fedora_lightbackground.svg, which is what the light background is currently using. It is 280x80 px.

We also ship /usr/share/fedora-logos/fedora_logo_darkbackground.svg, which is white and would be good for the dark version. It is a different size though, 908 x 415px.

Let me know if it would be helpful to ship a version of the white logo scaled precisely to the one currently used on the light backgrounds and I can work on that.

Comment 4 Matthias Clasen 2022-03-29 17:24:31 UTC
The fix for the missing logo over the dark default is here: https://pagure.io/background-logo-extension/pull-request/38

Comment 5 Florian Müllner 2022-03-29 17:39:07 UTC
(In reply to Máirín Duffy from comment #3)
> Let me know if it would be helpful to ship a version of the white logo
> scaled precisely to the one currently used on the light backgrounds and I
> can work on that.

The extension's size setting is relative to the screen size, so the result should be the same for any image with the same ratio, regardless of the original size.

Here the images don't have the same ratio, so there'll be some difference. It's hard to tell how distracting that difference will be without trying it.

That said, a same-size asset (or at least same ratio) can't hurt, if it's not too much work.


> mclasen pointed out we might want to use a different version of the logo for contrast against the dark mode background.

That means duplicating the logo-file setting for dark-mode, similar to what GNOME itself does for the background. The size and position settings should be independent from the mode, but duplicating the opacity settings as well may make sense?

Comment 6 Florian Müllner 2022-03-29 19:01:49 UTC
(In reply to Matthias Clasen from comment #4)
> The fix for the missing logo over the dark default is here:
> https://pagure.io/background-logo-extension/pull-request/38

I also pushed support for a separate dark logo there.

Comment 7 Fedora Update System 2022-04-04 18:44:12 UTC
FEDORA-2022-2a7028b1ab has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-2a7028b1ab

Comment 8 Fedora Update System 2022-04-04 19:30:18 UTC
FEDORA-2022-0fbc0247bf has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-0fbc0247bf

Comment 9 Fedora Update System 2022-04-05 00:17:25 UTC
FEDORA-2022-2a7028b1ab has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Fedora Update System 2022-04-05 12:41:16 UTC
FEDORA-2022-0fbc0247bf has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-0fbc0247bf`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-0fbc0247bf

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Máirín Duffy 2022-04-05 14:22:22 UTC
Re-opening because one of the two associated bodhi updates was missed in the compose last night and I need to submit a freeze exception.

Summary:

The Fedora logo was not showing up on the dark mode wallpaper, only the light mode wallpaper. There are two different Bodhi updates that are *both* needed to fix this issue, they are dependent on each other.

Bodhi Update #1: GNOME extension fix:
Florian submitted https://bodhi.fedoraproject.org/updates/FEDORA-2022-2a7028b1ab which was accepted to stable and included in last night's compose.

Bodhi Update #2: Fedora logo artwork fix:
Nils submitted https://bodhi.fedoraproject.org/updates/FEDORA-2022-0fbc0247bf but it is still in testing (it has +9 karma) so it was not included in last night's compose.

Because #2 didn´t make it into the compose and #1 did, the desktop logo is still broken - the file that update #1 needs and refers to is missing since #2 didn't make it in.

I will file a freeze exception next to make the case for including https://bodhi.fedoraproject.org/updates/FEDORA-2022-0fbc0247bf into F36 final past yesterday's freeze.

Comment 12 Fedora Blocker Bugs Application 2022-04-05 14:27:41 UTC
Proposed as a Blocker and Freeze Exception for 36-final by Fedora user duffy using the blocker tracking app because:

 The Fedora logo was not showing up on the dark mode wallpaper, only the light mode wallpaper. There are two different Bodhi updates that are *both* needed to fix this issue, they are dependent on each other. The update that fixed the issue for the GNOME wallpaper logo extension made it into the compose, but the update that supplied the artwork file that the GNOME wallpaper logo extension refers to did not somehow. So what made it in is broken. 

These are the relevant Bodhi updates:

Bodhi Update #1: GNOME extension fix:
Florian submitted https://bodhi.fedoraproject.org/updates/FEDORA-2022-2a7028b1ab which was accepted to stable and included in last night's compose.

Bodhi Update #2: Fedora logo artwork fix:
Nils submitted https://bodhi.fedoraproject.org/updates/FEDORA-2022-0fbc0247bf but it is still in testing (it has +9 karma) so it was not included in last night's compose.

An argument could be made that this is a blocker as this is the final artwork that is not displaying correctly, see: https://www.fedoraproject.org/wiki/Fedora_36_Final_Release_Criteria#Artwork

If you don't agree with the assessment that this is a blocker than I would like it to be treated as an FE.

Comment 13 Fedora Update System 2022-04-05 14:27:53 UTC
FEDORA-2022-0fbc0247bf has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Kamil Páral 2022-04-06 08:29:01 UTC
(In reply to Fedora Blocker Bugs Application from comment #12)
> Bodhi Update #2: Fedora logo artwork fix:
> Nils submitted
> https://bodhi.fedoraproject.org/updates/FEDORA-2022-0fbc0247bf but it is
> still in testing (it has +9 karma) so it was not included in last night's
> compose.

Some weird timing & Bodhi behavior occurred there, but the package looks to be part of the Fedora-36-20220406.n.0 compose, which should be pushed to repos later today or tomorrow for everyone.

Comment 15 Kamil Páral 2022-04-06 13:08:57 UTC
(In reply to Kamil Páral from comment #14)
> Some weird timing & Bodhi behavior occurred there, but the package looks to
> be part of the Fedora-36-20220406.n.0 compose, which should be pushed to
> repos later today or tomorrow for everyone.

fedora-logos-36.0.0-2.fc36.noarch is now pushed stable


Note You need to log in before you can comment on or make changes to this bug.