Bug 20695 - LPRng upgrade from 3.6.22-5 (RH 7.0 CD) to 3.6.24-2 or 3.6.26-1 breaks printing
Summary: LPRng upgrade from 3.6.22-5 (RH 7.0 CD) to 3.6.24-2 or 3.6.26-1 breaks printing
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: LPRng   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-12 02:59 UTC by sdh4
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-12 02:59:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description sdh4 2000-11-12 02:59:19 UTC
This is with netatalk. Everything worked fine on the stock RH 7.0

I get the error message below from lpq
[root@audiophile]# lpq
Printer: hp208@audiophile  'lp'
 Queue: 1 printable job
 Server: pid 30990 active
 Unspooler: pid 30991 active
 Status: cannot open '| -$ /usr/bin/pap -e' - 'No Error', attempt 1,
sleeping 10 at 21:47:12.332
 Filter_status: status: idle
 Rank   Owner/ID                  Class Job Files                 Size Time
active root@audiophile+989          A   989 /root/Xrootenv.0       574
21:47:12

The printcap is as follows:
hp208|lp:\
        :sd=/var/spool/lpd/hp208:\
        :sh:\
        :lp=| -$ /usr/bin/pap -e:\
        :lf=/var/log/lpd-errs:\
        :mx#0:\
        :mc=0:\
        :if=/var/spool/lpd/hp208/filter:

Downgrading to 3.6.22-5 solves the problem.

This problem seems to show up any time the lp output is piped
(it shows up with lp=| cat >/tmp/foo)

Comment 1 Crutcher Dunnavant 2001-02-01 22:03:26 UTC
Hmm, yeah, thats an issue.
It's fixed in the latest LPRng, but the one in rawhide has other issues that are
not quite dealt with yet, as a side effect of replacing the printing system, so
you might not want to grab that one (unless you want to copy your old lpd.init,
and reinstall lpd.init after you upgrade.)

I can't push this as an errata, because 7.0 (the only one to ship with LPRng so
far) didn't ever do this /itself/, as netatalk wasn't supported explicitly. I
/can/ tell you that the new version of LPRng in the beta fixes this.



Note You need to log in before you can comment on or make changes to this bug.