Bug 206961 - possible circular locking dependency: tcp_sendmsg/notify_change
possible circular locking dependency: tcp_sendmsg/notify_change
Status: CLOSED DUPLICATE of bug 205487
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-09-18 10:42 EDT by Joe Orton
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-03 15:48:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
lockdep dmesg output (5.69 KB, text/plain)
2006-09-18 10:44 EDT, Joe Orton
no flags Details

  None (edit)
Description Joe Orton 2006-09-18 10:42:13 EDT
[ INFO: possible circular locking dependency detected ]
2.6.17-1.2630.fc6 #1
bash/14405 is trying to acquire lock:
 (sk_lock-AF_INET){--..}, at: [<c05dcaa1>] tcp_sendmsg+0x14/0x9bb

but task is already holding lock:
 (&inode->i_alloc_sem){--..}, at: [<c048aa27>] notify_change+0xe5/0x2c2

which lock already depends on the new lock.

(i686 kernel)
Comment 1 Joe Orton 2006-09-18 10:44:31 EDT
Created attachment 136547 [details]
lockdep dmesg output
Comment 2 Linda Wang 2006-10-03 15:48:09 EDT

*** This bug has been marked as a duplicate of 205487 ***

Note You need to log in before you can comment on or make changes to this bug.