Bug 206983 - Cookie / session disagreement between perl and java
Cookie / session disagreement between perl and java
Status: CLOSED NOTABUG
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn420
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
wes hayutin
:
Depends On:
Blocks: 165365
  Show dependency treegraph
 
Reported: 2006-09-18 12:23 EDT by Ken Ganong
Modified: 2007-04-18 13:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-17 15:33:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Ganong 2006-09-18 12:23:35 EDT
Resulting behaviour: every time the user hits a perl page, it redirects them to
Your Rhn, making the perl pages useless.

Why:
In some cases, the java code validates a user as already logged in, while the
perl does not. This means that when a user requests a perl page, it decides they
are not logged in and then redirects them to the Relogin page (which never
appears). The Relogin page, being in java, decides that the user is logged in
and redirects them straight to Your Rhn.

Reproduction:
1. Log in
2. Go to Channels -> Manage Software Channels
3. Log out
4. Log in as a different user.
5. You will be at the Your Rhn page erroneously
6. Go to Systems -> select a system

Actual Results:
You are taken back to the Your Rhn page

Expected Results:
on step 5, you should be at the manage software channels page
after step 6, you should be at the selected systems details page.

Additional info:
if you log out of the second user and login again as the original user,
the perl pages will work again.
Comment 1 Ken Ganong 2006-09-18 12:25:09 EDT
assigning to acting team lead.
Comment 2 Jesus M. Rodriguez 2007-01-03 12:17:56 EST
TEST PLAN
------------
See original comment.
Comment 3 wes hayutin 2007-01-17 15:17:54 EST
it looks like you are supposed to be directed to yourRhn Page... so I'm not sure
what the issue is or how exactly the recreate works..


Why would two users get redirected to the same page as another user?
Returning.. need more info

Note You need to log in before you can comment on or make changes to this bug.