This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 207013 - eclipse doesn't upgrade cleanly from FC5
eclipse doesn't upgrade cleanly from FC5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-18 15:24 EDT by Mary Ellen Foster
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 3.2.1-4.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 11:27:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of "Features" window, showing weird versions (32.37 KB, image/png)
2006-09-21 17:39 EDT, Mary Ellen Foster
no flags Details

  None (edit)
Description Mary Ellen Foster 2006-09-18 15:24:11 EDT
Description of problem:
On a normal FC5 system, I upgraded to eclipse (+ dependencies) from Rawhide via
'yum --enablerepo=development update eclipse\*'. After that, Eclipse still seems
to think that RCP is version 3.1.2, which causes various problems.

Under Help-About-Features, for example, it says Eclipse RCP is version 3.1.2,
even though the build ID is M20060629-1906 (the same as the other components,
which are 3.2.0.v20060609*), and under Help-About-Plugins RCP is 3.2.0 too. If I
try to check for updates to third-party modules through the update manager, I
get the following warning:

----- Current configuration problems -----
Error creating feature
"file:/usr/share/eclipse/features/org.eclipse.rcp_3.1.2/".
[/usr/share/eclipse/features/org.eclipse.rcp_3.1.2/feature.xml (No such file or
directory)]
/usr/share/eclipse/features/org.eclipse.rcp_3.1.2/feature.xml (No such file or
directory)
----- Configuration problems after the operation -----
Error creating feature
"file:/usr/share/eclipse/features/org.eclipse.rcp_3.1.2/".
[/usr/share/eclipse/features/org.eclipse.rcp_3.1.2/feature.xml (No such file or
directory)]
/usr/share/eclipse/features/org.eclipse.rcp_3.1.2/feature.xml (No such file or
directory)

If I uninstall eclipse-rcp (and its friends) and then reinstall, then everything
is fine.

I suspect the problem is in the file
/usr/share/eclipse/configuration/org.eclipse.update/platform.xml, which contains
the line
    <feature id="org.eclipse.rcp" version="3.1.2"
url="features/org.eclipse.rcp_3.1.2/">

Version-Release number of selected component (if applicable):
3.2.0-5.fc6
(upgrading from 3.1.2-1jpp_15fc)

How reproducible:
Every time (happened on two FC5 machines so far, both fixed by uninstalling and
reinstalling Eclipse)

Steps to Reproduce:
1. Upgrade eclipse as described above on an FC5 machine
  
Actual results:
Messed up RCP

Expected results:
Working RCP
Comment 1 Ben Konrath 2006-09-18 17:33:16 EDT
I'm working on a fix for this and it should be done in the next couple of days.
You may also want to try these packages until we get 3.2 in FC5 but they
probably have the same problem:

https://www.redhat.com/archives/fedora-devel-java-list/2006-September/msg00008.html
Comment 2 Ben Konrath 2006-09-20 18:17:20 EDT
I think I fixed this in 3.2.0-6.fc6. Can you test and report back. Thanks.
Comment 3 Mary Ellen Foster 2006-09-21 03:24:25 EDT
I just tried -- had to jump through a few hoops to get the FC5 version installed
again, and then I updated to 3.2.0-6.fc6 from development. Now, eclipse doesn't
start up at all, and I get the following in workspace/.metadata/.log. I can't
immediately tell what's going on, but for the moment I'm going to have to
uninstall and reinstall because I need to use Eclipse on this machine today. If
you want me to test something else, I should be able to do it tonight.

!SESSION 2006-09-21 09:23:11.116 -----------------------------------------------
eclipse.buildId=M20060629-1905
java.version=1.5.0_06
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86

!ENTRY org.eclipse.osgi 2 1 2006-09-21 09:23:15.060
!MESSAGE NLS missing message: fileInitializer_missingFileName in:
org.eclipse.core.internal.runtime.messages

!ENTRY org.eclipse.core.runtime 2006-09-21 09:23:15.087
!MESSAGE Product org.eclipse.sdk.ide could not be found.

!ENTRY org.eclipse.osgi 4 0 2006-09-21 09:23:15.108
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
	at
org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:56)
	at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:92)
	at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:68)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336)
	at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
	at org.eclipse.core.launcher.Main.run(Main.java:977)
	at org.eclipse.core.launcher.Main.main(Main.java:952)
Comment 4 Mary Ellen Foster 2006-09-21 03:40:32 EDT
Okay, the above looks like a different bug, because it happened even when I
uninstalled and reinstalled Eclipse.
Comment 5 Ben Konrath 2006-09-21 10:24:23 EDT
(In reply to comment #4)
> Okay, the above looks like a different bug, because it happened even when I
> uninstalled and reinstalled Eclipse.

Yeah, bug # 207442 seems similar. Let's track this problem there.
Comment 6 Mary Ellen Foster 2006-09-21 17:38:50 EDT
Okay, going back to the problem that this bug is about, I just tried the following:
- Reinstall the FC5 Eclipse
- Update to eclipse* from development
- Install eclipse-sdk and all of its friends

It actually seems to have got worse; now, "About Eclipse SDK Features" says that
*all* of the core components are version 3.1.2, even though I'm definitely
running a 3.2.0 Eclipse. Actually, it thinks that JDT is version "-Z4XP", which
is probably even worse, and causes similar error messages to those I typed above
except with JDT and that version instead of RCP and 3.1.2. I'll attach a
screenshot of the "Features" window shortly.
Comment 7 Mary Ellen Foster 2006-09-21 17:39:59 EDT
Created attachment 136913 [details]
Screenshot of "Features" window, showing weird versions
Comment 8 Ben Konrath 2006-09-21 18:01:38 EDT
What version are you updating from?
Comment 9 Mary Ellen Foster 2006-09-21 18:07:54 EDT
The default from FC5 updates: 3.1.2-1jpp_15fc
Comment 10 Ben Konrath 2006-09-23 18:14:21 EDT
I'd like to reproduce your problem exactly. Can you provide a list of eclipse
pacakges you have installed on FC5 and provide the command you are using to
update Eclipse from development? Thanks.
Comment 11 Mary Ellen Foster 2006-10-02 11:27:56 EDT
Seems to be okay now with eclipse 3.2.1-4.fc6 ... must have been something
transient.
Comment 12 Ben Konrath 2006-10-02 12:20:03 EDT
(In reply to comment #11)
> Seems to be okay now with eclipse 3.2.1-4.fc6 ... must have been something
> transient.

Acutally, Andrew Overholt fixed this over the weekend. Thanks for filing the bug.

Note You need to log in before you can comment on or make changes to this bug.