Bug 207014 - can't configure x to work with radeon firegl v3400
can't configure x to work with radeon firegl v3400
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-18 15:26 EDT by Garrett Mitchener
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-27 16:59:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.99 KB, application/octet-stream)
2007-07-12 11:42 EDT, Garrett Mitchener
no flags Details
my X log (54.54 KB, text/plain)
2007-07-12 14:08 EDT, Garrett Mitchener
no flags Details

  None (edit)
Description Garrett Mitchener 2006-09-18 15:26:57 EDT
Description of problem:

I just installed fc6 test 3 on a new dell precision 690 with an ati firegl v3400
graphics card with a dvi monitor.  This card has two dvi ports.

After installing fc6 test 3 and rebooting, rhgb gave me a blank screen, so I
removed rhgb from the boot command line and tried again.  The first boot program
started and asked several questions, but it failed somewhere in the user account
creation screen and left me with a blank screen.  So I killed that off and
rebooted and X didn't work at all after that.  (It did work during the install
and in this first boot screen, go figure.)

I tried using Xorg -configure and the resulting xorg.conf file just tries to
start X with a VESA driver, but when I start X with that xorg.conf, the monitor
immediately goes into some sort of power save or sleep mode and shows nothing. 
Oddly, gnome and various X program run and apparently work, but X never shows
anything on the monitor.  I also tried using the text mode setup program, which
has an option to configure X, and whatever is suppopsed to appear to let me
configure X never appeared.

I also tried manually configuring xorg.conf.  I tried the ati and radeon
drivers, but I kept getting error messages about no device found.  I tried
specifying BusID "PCI:7:0:0" and "PCI:7:0:1" (which are the numbers for the
graphics card I get out of lspci) and that resulted in error messages about how
no Device section was found for (BusID "PCI:7:0:0").

X worked okay during the install -- I think it was using some sort of default
vesa mode.  Knoppix is also able to give me a working X screen.  I'll try to
post the xorg.conf it comes up with.
Comment 1 Matthew Miller 2007-04-06 15:39:40 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 2 Matěj Cepl 2007-07-11 17:45:05 EDT
Reporter, I am sorry, that we have left this bug unnoticed for so long, but
could you confirm please, that this bug still could be reproduced with the
latest updates of your distribution (Fedora or RHEL)?

If you are able to reproduce this, please attach your X server config file
(/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug
report as individual uncompressed file attachments using the bugzilla file
attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

If you won't reply in one month, I will have to close this bug as
INSUFFICIENT_DATA. Thank you.

Thanks in advance.
Comment 3 Garrett Mitchener 2007-07-12 10:16:14 EDT
I'm not sure exactly how to reproduce parts of this since it was an installation
issue and I need my workstation up and running for the forseeable future.  I'll
see what I can do and post stuff here.

I was able to do this one check pretty easily.  This may be part of the problem:

[root@grograman ~]# system-config-display 
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 377, in ?
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig,
rhpxl.videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 645, in __init__
    self.xml.get_widget("secondMonitorLabel").set_text(monitor_list[1].modelname)
TypeError: GtkLabel.set_text() argument 1 must be string, not None
[root@grograman ~]# 

I have only one monitor connected.
Comment 4 Matěj Cepl 2007-07-12 11:39:57 EDT
We could certainly use at least your current /var/log/Xorg.0.log and
/etc/X11/xorg.conf.
Comment 5 Garrett Mitchener 2007-07-12 11:42:06 EDT
Created attachment 159066 [details]
xorg.conf

This is my current working xorg.conf.
Comment 6 Garrett Mitchener 2007-07-12 14:08:17 EDT
Created attachment 159081 [details]
my X log

This is the X log.
Comment 7 Adam Jackson 2007-07-23 16:09:54 EDT
This X log shows the proprietary fglrx driver running, which we are unable to
support.  Does the vesa driver not work for you?
Comment 8 Garrett Mitchener 2007-07-23 16:41:28 EDT
The vesa driver did work when I last checked.

The problem is that when I installed fc6test3, the installation process failed
to set up a working xorg.conf.  I was able to manually write out a working
xorg.conf after the installation.
Comment 9 Adam Jackson 2007-08-27 16:59:52 EDT
The vesa driver has seen significant updates since then.  In particular the one
in F7 should be working as well as can be expected.  Since FC6 is rapidly coming
to end of life I'm not sure there's any work to be done here.

If possible, the /var/log/Xorg.0.log from the initial (failing) configuration
would certainly be useful information.  If you have it, please attach it and
reopen this bug.

Otherwise I'm just going to mark this as working in rawhide; please feel free to
reopen the bug if you experience more trouble with the vesa driver in the future.

Thanks for the report!

Note You need to log in before you can comment on or make changes to this bug.