Bug 207015 - mock-0.6-4 doesn't work with yum-2.9.6
Summary: mock-0.6-4 doesn't work with yum-2.9.6
Status: CLOSED CANTFIX
Alias: None
Product: Fedora Hosted Projects
Classification: Retired
Component: mock (Show other bugs)
(Show other bugs)
Version: unspecified
Hardware: All Linux
medium
urgent
Target Milestone: ---
Assignee: Clark Williams
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FE7Target
TreeView+ depends on / blocked
 
Reported: 2006-09-18 19:31 UTC by Mykola Ulianytskyi
Modified: 2013-01-10 04:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-25 14:52:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to handle rpmUtils import change (503 bytes, patch)
2006-12-14 17:09 UTC, Clark Williams
no flags Details | Diff

Description Mykola Ulianytskyi 2006-09-18 19:31:00 UTC
Description of problem:
mock doesn't work with new yum

Version-Release number of selected component (if applicable):
mock--.1 doesn't work with yum-2.9.6-1

How reproducible:
mock some_package.src.rpm

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
Traceback (most recent call last):
  File "/usr/bin/mock", line 986, in ?
    main()
  File "/usr/bin/mock", line 981, in main
    ensure_filetype_srpm(srpms)
  File "/usr/bin/mock", line 855, in ensure_filetype_srpm
    ts = rpmUtils.transaction.initReadOnlyTransaction()
AttributeError: 'module' object has no attribute 'transaction'


Additional info:

Comment 1 Clark Williams 2006-12-14 17:09:32 UTC
Created attachment 143661 [details]
patch to handle rpmUtils import change

Comment 2 Clark Williams 2006-12-14 17:12:59 UTC
Nikolay,

I haven't been able to recreate your problem, probably because I haven't been
able to track down an old version of yum.

Would you please try the attached transaction patch on your mock.py and see if
it fixes your problem?

Clark


Comment 3 Mykola Ulianytskyi 2007-03-17 18:53:02 UTC
Sorry, but i can't test it now because haven't old version of yum.
Propose to close the bug.

Comment 4 Clark Williams 2007-03-25 14:52:58 UTC
Yeah, I haven't been able to duplicate it. We'll close it and hope for the best :)


Note You need to log in before you can comment on or make changes to this bug.